Support » Installing WordPress » wp looking at index.php not index_wp

  • Resolved tim9021

    (@tim9021)


    apache displays index_wp.php, but when you click view site or go to edit template it looks for index.wp
    Does anyone have an idea about what I have wrong?
    Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Mark (podz)

    (@podz)

    Support Maven

    Where are you installing ?
    Which versions of apache etc have you got ?
    Is it broken before install ? Just after ?

    Mark (podz)

    (@podz)

    Support Maven

    Try using phpmyadmin to look inside the wp_options table and see what values for site_url and home are.

    blogfilename is index.php, siteurl is http://127.0.0.1
    How can I correct it?

    oops, got it. I changed it.
    One other question if I may, when I click login it gives me a directory listing instead of login or taking me to ‘write’.
    What’s going on there?

    Mark (podz)

    (@podz)

    Support Maven

    Looks like it isn’t recognising the .php extension as a file to be loaded as index.
    Have a look inside the http.conf file in apache – there’s a ton of options, but one will deal with file extensions. Add .php to the list.

    .php is added as an extension.
    If I click ‘register’ in wp, it does what is should; However, if I click ‘login’ it gives me a directory listing of ‘wp-admin’.
    Thanks for your help, I’m sure you’ve seen it 100’s of times, but you are a life-saver!

    Mark (podz)

    (@podz)

    Support Maven

    If you are logged in, and you click ‘login’ it should whizz along to index.php, which then just checks you really are logged in, and it then throws you to /post.php
    Now either wp-admin/index.php is missing, or your setup is missing index.php for some reason.
    Which apache/mysql/php setup are you using ? xampp ? foxserv ?

    To be honest, I’m not sure. I’m fairly new to all this. I do not believe it is foxserv though.
    wp-admin/index.php does exist.

    Mark (podz)

    (@podz)

    Support Maven

    I’m on XP Home, and xampp ( http://www.apachefriends.org/en/xampp-windows.html – get the installer download) has not given me any problems with wp, mediawiki or me just playing with stuff.
    I cannot see why it would not see index.php

    ok, thanks. You have been immensely helpful. Have a great day.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wp looking at index.php not index_wp’ is closed to new replies.