Support » Fixing WordPress » “wp-login.php” redirects to 404 not found

Viewing 12 replies - 1 through 12 (of 12 total)
  • What did you do immediately before it went wrong? Changed your Permalinks? Changed your blog url/wordpress url? Installed/upgraded a plugin?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Also what is the URL of your blog?

    Hello, and thank You for your answers.


    1) Since the site is in a developing phase, it was an habit for me now and then to visit the permalink page just to save the setting without changing it (I was told this could help wp working without cache issues).

    2) I didn’t changed the URL of the site.

    3) Yes, I installed a plugin yesterday but in this phase it happens that I install and/or uninstall plugins, but frankly I didn’t notice problems with this.

    @ Ipstenu:

    1) This is not a production site since I’m still developing/testing it locally wuth wamp/xpsp3. However I have wp installed within a subdirectory like “[my-site-domain]/name-of-subdir/”.

    I tried to change the theme folder name, it didn’t worked the 404 remains.

    Any hint would be appreciated. Could you tell/know how I could try just to enter dashboard?

    Thank You very much


    I’m not that familiar with WAMP, so hopefully someone else will chime in here. You might want to try deleting your wordpress .htaccess file though (assuming WAMP supports that)

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Hello alism, thank You.

    I tried what you suggested but now after hit the login button in wp-login.php I get an “Internal Server Error”.

    Btw, this is the content of the main .htaccess file (the one within the directory where wp is installed):

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /web/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /web/index.php [L]
    # END WordPress

    @ Ipstenu, thank you.

    I tried both, and both return 404 error NOT FOUND.

    From wp-login.php page I am redirected to a bogus “[my-site-domain]/login” page (this structure imitates the navigation toolbar URL I see when redirected)

    While from “wp-admin” I am redirected to “http://[my-site-domain]/wp-subdir/login?redirect_to=http%3A%2F%2F[my-site-domain]%2Fwp-subdir%2Fwp-admin%2F

    So that I can’t login and enter the dashboard.


    Anyone never experienced the issue to be redirected after login to a non-existent page?

    I want to disable all my plugins from within phpMyAdmin (since I can’t enter dashboard), is that possible? And if it is, how?

    I just would like to investigate if the redirection problem i’m experiencing is due to some plugin I have installed.


    I solved my problem, I post what I did for the record:

    1. in the “wp-content” folder I changed the name of the “plugins” folder to “” (whichever name would be fine)
    2. I logged at “[my-site-domain]/wp-login.php” but this time without to be redirected, so that I was able to enter the dashboard
    3. I renamed back to “plugins” the “” folder name (see step 1)
    4. within “Dashboard > Plugin” I reactivated all the plugins that were active before I experienced the issue of being redirected at login, all but one plugin which I think could be the culprit of the problem.
    5. logged-out and relogged-in, just to verify that the redirections disappeared.

    Thank You



    OPS I have a similar issue but this doesnt solve anything for me 🙁

    Please help..

    I had same issue, your suggestion got me in to fix, but am yet to be able to re-activate many of my plugins. Activated some and am just dealing with the fact that I wont be able to use anymore, which is odd, but too tired to deal with it now.

    Moderator t-p


    @zahed_1, have you tried loging to (please replace ‘’ with your actual domain name and extension).

    If that does not work, have a read of this codex guide:

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘“wp-login.php” redirects to 404 not found’ is closed to new replies.