The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] wp-login.php problem? (17 posts)

  1. Digg50
    Posted 7 years ago #

    The install for v 2.7 went fine using fantastico.

    I've installed it on a sub-directory like this /public_html/m54-iphone

    Then I go to the index through the domain I've parked on this directory and click on admin to get into the admin.

    I then enter the correct user name and password that I had emailed to me during the install.

    This is where the problem is. The page just reloads with a blank login page again.

    In other words! I can't get into admin Can you tell me what's going on?

    I've installed wordpress in earlier versions without a hitch. I'm stumped!!

    I'd appreciate any help with this.

    Thank you kindly

  2. MichaelH
    Posted 7 years ago #

    Fix your siteurl and/or home values in your database:

  3. Digg50
    Posted 7 years ago #


    I appreciate your reply but I followed your advice and checked the home values but they were correct without the trailing slash in the database.

    Now when I paste the url into the browser for that blog the home page comes up with a trailing slash...

    Any other checks?

  4. sim2008
    Posted 7 years ago #

    @Digg50, hey, Did you find a fix? Are you able to access your blog? I'm having the same problem and have no fix as of yet! I've created another post with extra details in the hope that someone will look at it, as I weren't 100% convinced we were having the same problem;

    Check it out here



  5. Niteblade
    Posted 7 years ago #

    Are you using PHP 5 by chance? We're kinda talking about the same issue here : http://wordpress.org/support/topic/225819?replies=11

  6. Digg50
    Posted 7 years ago #

    Hey sim2008 - at least I'm not alone here. No remedy yet here.

    Niteblade - it is PHP 5.2.6

    I've got 5 of these I'm trying to get into. Actually I have got into a couple of them - these are all on a subdirectory and where it did work is when I went back and did a 301 permanent redirect. But that hasn't worked on all of them for some reason.

  7. MichaelH
    Posted 7 years ago #


    If this is the domain in question:

    The login link takes me to:

    and on the login page it has a link to return to;

    If that isn't the domain in question it still makes me wonder about how your add-on domains are 'configured'.

  8. Digg50
    Posted 7 years ago #


    Yes that is one of the domains in question.

    Please let me know if my configuration is correct here;

    I have that domain 1ipod-shuffle.com pointing to the http://www.topanxiety-disorders.com/1ipod-shuffle/ directory
    then I also have a 301 redirect with the Redirect with or without www. selected.
    Then in the redirects to tab I put http://www.2-4iphone.com

    So that's how that one is configured

    Let me know if there's another/better way to do that.


  9. MichaelH
    Posted 7 years ago #

    On a cPanel host I don't have to do any redirects to get Add-on domains to work properly.

    Typically your main domain has a web-root of public_html, but then other domains will be in public_html/domain1 (or whatever folder you specify for each). But just creating/designating the Add-on domain is enough without doing redirects.

  10. Digg50
    Posted 7 years ago #

    I finally got a fix on my problem.

    Mine was a new install into a sub-directory and then I couldn't log-in the same as everybody above.

    What I did, I got the new URL pointed at the right sub-directory without any redirects in place.

    Then I went into cPanel/file manager to the functions.php file located at here wp-content/themes/default/functions.php

    Then Edit this file at the very top of the functions.php file on the next line after the <?php
    add these two pieces of code:


    Then go and log-in to the blog admin a couple times.
    like at the new address: /wp-login.php

    Then go and remove the two pieces of code listed above from the functions.php file .

    This was just for a new wp-install but I've done this on a couple that i was having the same trouble as above and that fixed it.


  11. robmmad16
    Posted 7 years ago #

    I tried that piece of code and deleted it, but it didn't do a thing for me. The only thing I do not get is when you say:

    I got the new URL pointed at the right sub-directory without any redirects in place.

    What do you mean, where and how must I edit this file...

  12. robmmad16
    Posted 7 years ago #


  13. kellychung
    Posted 7 years ago #

    I installed wordpress 2.7
    I almost got the final step. I was watching Turning WordPress On | Tutorial #8 http://www.otisteaches.com/tutorials/turning-wordpress-on-tutorial-8/ Am i watching an old video?

    He mentioned we should have wp-login-php page: the system will give me a uername, password.
    When I type :http://yourmoneyandyourworld.wordpress.com/wp-admin/install.php, I got the error message :Easy, tiger. This is a 404 page.

    how can i get: http://yourmoneyandyourworld.wordpress.com/wp-login-php. Pls fix it for me. Do i need to download another wordpress?

    But I can go to http://yourmoneyandyourworld.wordpress.com/wp-admin/profile.php.
    Pls double check my profile. Am I suppose to have any wp-login-php attach my webaddress for web uploading purpose? Many thanks>

  14. exodusfrom9to5
    Posted 7 years ago #

    Same with robmmad16

    I tried the two codes. Didn't work

    I also don't understand

    I got the new URL pointed at the right sub-directory without any redirects in place.

    Please help

  15. sybold
    Posted 7 years ago #

    i maybe found the possible problem
    see here

    can you try and confirm this, thanks

  16. maibam
    Posted 7 years ago #

    After installation of WordPress 2.7.1 I get this while trying to log in the //wp-admin/

    Directory Listing Denied
    This Virtual Directory does not allow contents to be listed.

    What does this mean. Can anyone Help me out?? Pliz

  17. fle
    Posted 7 years ago #

    finally for me worked this solution http://wordpress.org/support/topic/210217?replies=2
    it was all about a plugin which I had installed .. it was a purpose of redirecting ..

Topic Closed

This topic has been closed to new replies.

About this Topic