Support » Fixing WordPress » wp-login

  • When I tried to login, it keeps sending me to the next page with nothing in it, a blank page, where it says redirrect= it’s empty field.

    I have changed my wp-login.php from what’s suggested from the forum.

    Do I need to do something else?

    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator James Huff


    Thank you for the reply, but you probably missed it when I stated “I have made the changes as suggested on that page”




    1) did you reset the siteurl setting?
    2) did you clear out your cache?


    Yes, and yes.

    Same here. I am running the Feb 5 nightly. Just yesterday I had 3 different test users (all on Mac’s, using IE, FireFox and Safari) that never even went to the site before and they had the same login problem.

    Right now the only solution we’ve found is after trying to login and getting the blank screen we go to the /wordpress/wp-admin url (from a bookmark), the admin pages then show up, so it’s clear the login itself actually works and that apparently it’s the redirect that’s the problem.

    If it’s a cookie problem it should be easy to clear up the cookies on the first visit no?

    WP is amazing, but I don’t understand why it’s taking so long to fix the login. Login is the most basic function no?

    Thank you.

    Thank you for the reply, Mosco. I have tried your solution but it still doesn’t solve my login problem.

    I am using IE, FireFox and Safari as well.

    I’m working my way through the errors on my login page. After I log in I get these errors…..

    Warning: Cannot modify header information – headers already sent by (output started at /data/members/free/tripod/uk/s/e/a/seanb/htdocs/wp-config.php:34) in /data/members/free/tripod/uk/s/e/a/seanb/htdocs/wp-login.php on line 164

    Warning: Cannot modify header information – headers already sent by (output started at /data/members/free/tripod/uk/s/e/a/seanb/htdocs/wp-config.php:34) in /data/members/free/tripod/uk/s/e/a/seanb/htdocs/wp-login.php on line 165

    I had alot more errors like that so just removed the header code before it and they stopped coming up. Just not sure how to fix these to?

    Moderator James Huff


    tbh I don’t really understand that…….

    This is the code I’ve around those lines…

    if ($user_login && $user_pass) {
    if ( wp_login($user_login, $user_pass, $using_cookie) ) {
    if (! $using_cookie) {
    $user_pass = md5(md5($user_pass)); // Double hash the password in the cookie.
    setcookie(‘wordpressuser_’. COOKIEHASH, $user_login, time() + 31536000, COOKIEPATH);
    setcookie(‘wordpresspass_’. COOKIEHASH, $user_pass, time() + 31536000, COOKIEPATH);

    if ($is_IIS)
    header(“Refresh: 0;url=$redirect_to”);

    Moderator James Huff


    Check wp-config.php and wp-login.php. Make sure that there are no blank lines or spaces before the first <?php and no blank lines or spaces after the last ?> .

    I not really having much luck with this now, could someone send me their working login.php file to me at


    Moderator James Huff


    Just grab a new one from a fresh WP download.

    If I do that then I’ll just get all the errors back.

    Found a weird thing today, I fresh-installed this on different server and it’s working fine. So I fresh install on the server I had problem with, and it still having the same problem as mentioned earlier.

    The only different is I includes the interpreter line #!/usr/local/bin/php4, in the first line of the code.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘wp-login’ is closed to new replies.