WP Links: IE vs. Firefox (13 posts)

  1. dvmorris
    Posted 10 years ago #

    I have a site i'm working on setting up, and IE doesn't seem to like some of the links, while firefox treats them as it should:


    Anyone who runs both ie and ff, could you check it out and possibly offer any advice?

    in ie my links in the "events category" don't work, but in ff they do.



  2. billh
    Posted 10 years ago #

    This link displays identically in IE and FF on my system.

  3. dvmorris
    Posted 10 years ago #


    this is what mine looks like in ie... ???

  4. petit
    Posted 10 years ago #

    The link you gave above give the same dull impression in Firefox and in IE. Going to the root http://dave.showviz.net/172/ works well in both browsers.

    There is something wrong with your permalinks though. The link to "Your first assignment" under Events doesn't work.
    If you go to the posts for January it shows up and the title link of the post is the same as that under Events. Clicking the title should lead to a single page for that post.

    You should check your .htaccess file and maybe recreate it to get the correct rewrite rules. If you are running WP 2.0 the rules should be written automatically to .htaccess when you set up your permalink structure and click the Update button.
    If you are on a windows system, the .htaccess may not work.

  5. dvmorris
    Posted 10 years ago #

    I followed the instructions here


    and set permissions on an empty htaccess file, then i changed my permalink structure to numerical...

    ff reads it right, ie wrong.

    then i tried back to default from scratch with a new htaccess file, and it's doing the same thing.

    i have deleted the htaccess over and over and started a new one, chmod 0666, and all that jazz, and it still won't work.

    what am i missing here? I feel stupid.

  6. dvmorris
    Posted 10 years ago #

    with the default setting chosen for permalinks, this is what my htaccess looks like

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /172/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /172/index.php

    # END WordPress

  7. petit
    Posted 10 years ago #

    Hi dvmorris!

    I hope someone else jumps in here - I'm out of ideas.
    You say "ff reads it right, ie wrong."

    I don't agree.
    If I click the link http://dave.showviz.net/172/?p=6 under Events in my Firefox browser ( ver. 1.5 ) under Windows XP, it doesn't show your post "Your first assignment!",
    which has that permalink.

    AS far as I can see, the results are the same in FF and MSIE.

    Good luck!

  8. dvmorris
    Posted 10 years ago #

    wow, i still have the same problem, and it seems my students cannot post comments from ie either. i've never had problems with wp before... thanks anyway for your help, maybe someone else will notice the post...

  9. petit
    Posted 10 years ago #

    Hi dvmorris!

    It seems that you managed to solve the faulty permalink problem. At least just now I was able to get the link work in both MSIE and FF.

    Please share the solution with us, if you will!

    And if everything is okey, you may mark this thread as "resolved".

  10. dvmorris
    Posted 10 years ago #

    yes, this is correct. everything seems to be working fine. the only problem is that I didn't seem to do anything to make this happen... ? oh well. at least it works. thanks for the attention.

  11. petit
    Posted 10 years ago #

    Well, that's the common mystery of a computerized world.
    Some problems and resolutions can't be explained; they just happen ;-)

  12. gelle
    Posted 10 years ago #

    Im having a similar problem. Here (Michigan) i can see this post in firefox but not in IE.


    My dad in Denmark cant see it in any of his browsers. If anybody has an idea for a fix - I would be very interested.

  13. gelle
    Posted 10 years ago #

    Doh! At some point I had accidently set the post status to Private so it was only in my login browser it was visible. My bad.

Topic Closed

This topic has been closed to new replies.

About this Topic