Support » Plugin: WP Knowledgebase » Wp Knowledge Base keeps using old slug

  • Resolved chojiro

    (@chojiro)


    I am running into an odd issue as of today.

    If I change the slug away from knowledgebase and use the old slug, it links me to the old page as if it still exists when I try to use it, where as before it would give me an error, which I’d expect. the new slug won’t work, even if I attempt to create a new page and insert the shortcode. Even if the slug doesn’t correspond to the new page, it errors when I try to create a page using it, saying that the update or publishing of the page failed. As soon as I remove the shortcode, that goes away.

    So far, I have tried reinstalling the plug-in from scratch, but no luck. The knowledge base page shows the title “knowledge base archive”, even though that’s not actually the name of the page itself. It looks more like the plug-in doesn’t care at all what my settings are. Weirdly, if I reinstall the plug-in, keeping no settings, the slug I used to use sends me to the knowledgebase page, even though that isn’t the actual slug and contains no shortcode.

    As far as I know, nobody has screwed around with the WordPress installation to cause an issue like this, although I’m still looking into that. Any advice that might help? Could anything more central to the WordPress installation be overriding the plug-in settings, such as they are? I particularly wonder this because it redirects now to the main page when the plug-in is uninstalled.

    Sorry if this is a bit out of scope.

Viewing 1 replies (of 1 total)
  • Plugin Author Maeve Lander

    (@enigmaweb)

    In this order:
    1. Change the knowledgebase slug on the Knowledgebase settings screen. Save.
    2. Open the existing page with the kb and manually change it’s permalink to match your new slug. Save.
    3. Go to settings > permalinks and re-save your permalink structure.
    4. Clear your computer’s cache and browsing data. Close and Re-open the browser, then visit the new kb page.

    Let me know how you go

Viewing 1 replies (of 1 total)
  • The topic ‘Wp Knowledge Base keeps using old slug’ is closed to new replies.