Support » Fixing WordPress » WP keeps adding all my posts to “Uncategorized”

  • Resolved justinaugust

    (@justinaugust)


    Why does WP keep adding all my posts posted from Ecto.app to my Uncategorized category? It does this for my Flickr’d posts as well.

    I can try to uncheck the box, but it always gets added to the category. The only way I’ve found to fix it is to go into the WP post editing page and untick it there.

Viewing 6 replies - 16 through 21 (of 21 total)
  • johnoz

    (@johnoz)

    I have now been able to get image upload to work by unchecking UTF-8 Encoding in ecto.

    ecto

    (@ecto)

    Follow the directions at http://ecto.kung-foo.tv/archives/001427.php and you should be ok.

    Guntis

    (@guntis)

    Still seems to be one small problem – images are uploaded, but the links are wrong, at least they don’t work on Localhost (I have not opportunity to test them on real Internet-connected server).
    Problem is here:

    <a href=”/wp-content/iMac%20-%20aside-1.jpg” onclick=”window.open(‘/wp-content/iMac%20-%20aside-1.jpg’,’popup’,’ ….

    There is one extra slash that breaks link – instead of
    <a href=”/wp-content/
    should be
    <a href=”wp-content/

    And this is done in all three “<a href=”/wp-content/” instances.

    ecto

    (@ecto)

    macgizmo

    (@macgizmo)

    I can confirm that the two files (functions-post.php and xmlrpc.php) that are provided at ecto’s link three posts up do in fact correct the problem with categories always setting to default. I’m using the latest version of ecto and WP.

    I was having the same trouble with Flickr posting to my default category. I wrote a hack/plugin to fix it. You can read about it here.

    This will allow you to choose what category you want flickr to post into. I am running this with wordpress 1.5.2

    http://www.rossgerbasi.com/?p=131

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘WP keeps adding all my posts to “Uncategorized”’ is closed to new replies.