WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WP keeps adding all my posts to “Uncategorized”

[Resolved] WP keeps adding all my posts to “Uncategorized”

  • Why does WP keep adding all my posts posted from Ecto.app to my Uncategorized category? It does this for my Flickr’d posts as well.

    I can try to uncheck the box, but it always gets added to the category. The only way I’ve found to fix it is to go into the WP post editing page and untick it there.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I don’t use ecto, but the short answer is that it looks like a bug in WP, which has been logged, and which you can fix with a few quick edits to your xmlrpc.php

    See this forum for the quick-fix, or (at much greater length) this thread.

    Thanks

    v.1.5.1.3 did some changes in xmlrpc.php file, now the lines that mess up this thing look like this:

    $post_category = array();

    if (is_array($catnames)) {
    foreach ($catnames as $cat) {
    $post_category[] = get_cat_ID($cat);
    }
    } else if ( !empty($catnames) ) {
    $post_category = array(get_cat_ID($catnames));
    }

    but still I cannot post feeds from ecto to the correct categories – all end up in the default category!
    I tried to change code according to the examples in the ecta forum, but couldn’t get any results (see Guntis’ posts there):
    forum
    Can someone from WP look into this issue?

    Moderator James Huff

    @macmanx

    Support Team Rep.

    A fix for this problem has been made available in the form of xmlrpc.php revision 2680.

    >>A fix for this problem has been made available in the form of xmlrpc.php revision 2680.

    This does not fix the probelm on my system. Ecto and WP 1.5.1.3 still do not play together I am unable to post from ecto to a categories and make it stick. WP changes it each time to my default!

    I can confirm that the revision 2680 doesn’t fix the problem with Ecto on my Mac too… The same problem of saving all feeds to the default WP category. I have renamed default category to Misc. Maybe that’s the problem, but it shouldn’t be, because in Ecto I see all categories correctly. Ecto uploads edited feed and then category change takes place.

    A fix is described here:
    http://ecto.kung-foo.tv/archives/001427.php

    The problem here is that whoever coded the latest upgrade to xmlrpc.php did not realize that with MovableType API, categories are passed in mt.setPostCategories and NOT in metaWeblog.newPost or metaWeblog.editPost.

    Sounds like ecto doesn’t follow up the call to metaWeblog.editPost with mt.setPostCategories. All of my clients call mt.setPostCategories after both metaWeblog.editPost and metaWeblog.newPost. After a quick glance at the patch, I’m failing to see how it helps. That might just be because I haven’t had lunch yet. I’ll look at it later and try to fix this up. Thanks.

    metaWeblog.editPost is called AFTER mt.setPostCategories. That’s the MovableType API way. It’s always been like that and it’s how it works, because of a glitch in MT itself. In MT, mt.setPostCategories changes won’t be published unless you call metaWeblog.editPost. I don’t know what clients you test, and I’m surprised you didn’t use ecto to test. After all, a lot of WP users use ecto.

    The “patch” I uploaded isn’t the best solution. It just mostly reverts back to 1.5.1.2. The best way to fix it is not to set categories if none are passed in editPost and categories are already set in the db entry for the post.

    Btw, ecto user complain 1.5.1.3 is doing way too much escaping. You can’t even upload images since it seems to mess up the base64.

    The problems with too much escaping, including image uploads, are fixed. The fixes were rolled into the 1.5.1.3 tarball for now (yeah, I know). Re-download.

    ecto doesn’t run on Linux, as far as I can tell, so I can’t test with it. I test with four different clients and try to get other people to fill in the gaps. ecto seems to be unrepresented on our hackers and testers lists. I encourage ecto users to join the testers list and help us ensure good ecto support.

    Thanks for the MT background. I didn’t know that, and none of the clients I test with seem to know that either. I’ll fix things up.

    Sorry Ryan can I clarify? It’s 1:30am here and I’m getting sleepy! Do you mean that if I drag down another 1.5.3 then the fixes for ecto categories/images etc., are all now fixed? Presumably I only need to upload XMLRPC.php yes?

    Plus I’m happy to join a testing group for this – where do I sign up?
    (I know – look in the Codex. Fair enough. Tomorrow!)

    Yes, download 1.5.1.3 again and it will have fixes for everything except the category problem. xmlrpc.php and functions-post.php are the only files you need to update. Yes, not bumping the version is confusing. Now that the security bug is resolved and the collateral damage contained, I can take some time to get the category problems uncovered by ecto ironed out. Once that is fixed, maybe we can push a 1.5.1.4.

    If you want to help us test, join the Testers mailing list. I’ll be sending a hopeful fix for the category bug there soon.

    I joined the list and sent an email there. Thanks for the work on patching this all up. The category issue is easily fixed as I described in the email.

    I have installed the ecto patch and it worked for the Category problem but the Image upload problem came back. Same as before–images are uploading okay but are being corrupted, so they do not display. I am using WP 1.5.1.3 and ecto 2.3.6 on a Mac OSX.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] WP keeps adding all my posts to “Uncategorized”’ is closed to new replies.