Support » Plugin: WP REST API (WP API) » wp-json.php works OK but all other URLS 404

  • Resolved perryb


    Hi – I’m running WP on Nginx with pretty permalimks set up.

    After a bit of tinkering – installing via the Plugins > Add new didn’t work, I had to manually copy the files into my root and wp-includes – I got an output at mydomain/wp-json.php.

    Even though the links appear to mydomain/wp-json.php/posts etc (I’m using Firefox Json View) each one 404s.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Dalton Rooney


    Did you refresh your permalinks after copying the files over to your WP installation?



    Yes I did – it turns out that the placement of the plugin files caused the problem.

    I realised that the pages weren’t 404ing and were just blank so I switched debug back on and got this:

    Warning: include_once(/ failed to open stream: No such file or directory in / on line 13 etc....

    So I copied the files back into the plugin folder and everything seems to be working fine now.

    Not sure why the initial plugin install didn’t work – and manually copying files only partially worked.

    Hope this helps

    Plugin Author Ryan McCue


    The integrated option is not recommended, and will break at the moment. Sorry about the unclear documentation on that.

    I’m getting the same thing…the initial curl for wp-json.php works, but everything else 404s (according to the header). I’m watching my debug.log, but no warnings about the server file not being found. I downloaded the plugin via the wordpress dashboard, then went onto the server and moved the two files as instructed. Then I experienced a brief moment of joy when the initial curl command worked to just wp-json.php. Followed by the familiar letdown of realizing nothing else fetched any json.

    My site url has an ip. So it’s http://34.654.xx.xx/sitename/

    Will it work with this structure? What do you mean by integrated option?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp-json.php works OK but all other URLS 404’ is closed to new replies.