WordPress.org

Support

Support » Plugins and Hacks » WP REST API (WP API) » [Resolved] wp-json.php works OK but all other URLS 404

[Resolved] wp-json.php works OK but all other URLS 404

  • Hi – I’m running WP on Nginx with pretty permalimks set up.

    After a bit of tinkering – installing via the Plugins > Add new didn’t work, I had to manually copy the files into my root and wp-includes – I got an output at mydomain/wp-json.php.

    Even though the links appear to mydomain/wp-json.php/posts etc (I’m using Firefox Json View) each one 404s.

    Cheers

    http://wordpress.org/plugins/json-rest-api/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you refresh your permalinks after copying the files over to your WP installation?

    Yes I did – it turns out that the placement of the plugin files caused the problem.

    I realised that the pages weren’t 404ing and were just blank so I switched debug back on and got this:

    Warning: include_once(/mydomain.co.uk/public/wp-content/plugins/json-rest-api/lib/class-wp-json-server.php): failed to open stream: No such file or directory in /mydomain.co.uk/public/wp-content/plugins/json-rest-api/plugin.php on line 13 etc....

    So I copied the files back into the plugin folder and everything seems to be working fine now.

    Not sure why the initial plugin install didn’t work – and manually copying files only partially worked.

    Hope this helps

    Plugin Author Ryan McCue

    @rmccue

    The integrated option is not recommended, and will break at the moment. Sorry about the unclear documentation on that.

    I’m getting the same thing…the initial curl for wp-json.php works, but everything else 404s (according to the header). I’m watching my debug.log, but no warnings about the server file not being found. I downloaded the plugin via the wordpress dashboard, then went onto the server and moved the two files as instructed. Then I experienced a brief moment of joy when the initial curl command worked to just wp-json.php. Followed by the familiar letdown of realizing nothing else fetched any json.

    My site url has an ip. So it’s http://34.654.xx.xx/sitename/

    Will it work with this structure? What do you mean by integrated option?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] wp-json.php works OK but all other URLS 404’ is closed to new replies.
Skip to toolbar