Support » Plugin: Mailchimp for WooCommerce » /wp-json/mailchimp-for-woocommerce/v1/queue/work is slowing the website down

  • Resolved Amir

    (@amirmyb)


    After I installed Mailchimp on my woocommerce, the website is being slowed down by the script /wp-json/mailchimp-for-woocommerce/v1/queue/work.

    Is there any way to resolve this as it is adding an additional 2 seconds to the page lodad time.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Hi Amir,

    I have the exact same issue for a WP/Woocommerce site. The server requests itself every 1-2 seconds which causes MySQL CPU usage to peak at 100%. This started yesterday evening at 8pm – nothing has been changed in our end…

    Entry from the Apache log:

    http://www.site.dk 1.2.3.4 – – [02/May/2019:13:36:00 +0200] “GET /wp-json/mailchimp-for-woocommerce/v1/queue/work HTTP/1.1” 200 30 “https://www.site.dk/wp-json/mailchimp-for-woocommerce/v1/queue/work” “WordPress/5.1.1; https://www.site.dk”

    I have tried restarting mysql and apache, has no effect. Only solution is to disable the plugin.

    Have you found a solution for this ??

    /Jesper

    • This reply was modified 7 months, 2 weeks ago by haggren.

    Nothing yet, It is causing a load time delay of 2 seconds. Plus the additional load on server makes it throw random 500 errors (IDK why but after installing the plugin I randomly get to see 500 errors).
    No support from the plugin and no official reply yet.

    I have the same problem: /wp-json/mailchimp-for-woocommerce/v1/queue/work

    It’s slowing down my website, did you solve it?

    Plugin Author ryanhungate

    (@ryanhungate)

    @amirmyb @whatswrong these requests are supposed to be ‘non-blocking’ meaning it should not impact the page loading times. We specifically have a timeout built in of .01 second which should feel like nothing is even happening at all.

    If you were able to set up the plugin correctly, we’re assuming that the functionality is correct where your server should be able to accept the incoming connection and process that in a separate process ID which is out of the scope of your current visitors.

    That being said, if you’re a store that doesn’t have a ton of traffic, and possibly on a really small web server / hosting plan etc., we can try one thing for you where we disable the “long polling” of the queue and process only 1 job at a time.

    You may do that by adding a configuration in your wp-config.php file of:

    define('MAILCHIMP_DISABLE_QUEUE', true); and that should shut off the long polling you’re experiencing which might actually help you here. Please note that this is NOT the recommended approach for a site with reasonable traffic and shopping activity.

    Let us know if that does the trick, but you may want to consider an upgrade on your hosting plan to allow for more activity. We will get you all squared away somehow.

    It’s not due to my hosting plan, it has to do something with the plugin.
    I have a good plan with siteground, I don’t have many visitors a day.

    see result: https://gtmetrix.com/reports/zenluscious.com/CCEHd4jp

    Plugin Author ryanhungate

    (@ryanhungate)

    @whatswrong have you tried implementing the define('MAILCHIMP_DISABLE_QUEUE', true); setting mentioned above? If you don’t have a lot of traffic on your site you could probably get away with this setting.

    Hello

    @ryanhungate I have implemented the setting in wp-config and it seems to be working however I have a question why is it not recommended for high traffic/shopping activities websites? And what is your definition of high traffic? 🙂

    Plugin Author ryanhungate

    (@ryanhungate)

    @s4ndr0wy the reason we recommend keeping the typical settings for the queue is to processes jobs in the background effectively at the server level.

    The default setup keeps a single background process ( 1 request ) open long enough to process in upwards of 10-20 jobs depending on server resources and job types.

    This setting that you’ve applied makes the server accept a single request per job which over time for busier sites is not recommended.

    Higher traffic would be any store that has more than 10 people online at the same time, all doing things related to the shop like adding things to the cart, or placing orders etc.

    It’s subject to interpretation per person / per store too 🙂

    Ok so it is definetly not a solution for my website. Any other way around for that problem? 🙂

    Hello @ryanhungate ,

    I am experiencing the same with a couple clients. Is there another option we could use for sites with more than 10/day?

    Thank you!

    I have the same problem

    Facing same issue here. What I observed is that when this plugin is activated, any cart related actions (e.g. add to cart, update cart etc) will add about 2 seconds of delay to the response.

    It’s quite obvious because when I deactivated the plugin, my AJAX add to cart gives a response almost immediately. When it is activated, there’s always about 2 seconds delay.

    I already added define(‘DISABLE_WP_HTTP_WORKER’, true) in wp-config file too. And also added the cron job to run every minute. But it doesn’t seem to help.

    My website is running on Digital Ocean droplet, 2GB ram with 2vCPU. We are still testing it so there is not much traffic.

    Is there any other way to prevent the delay? Can we instead run the cron job every 5 minutes? Not sure if that will help though

    Camilo

    (@camilo517)

    I was locked the api rest, the only thing I did was exclude this plugin and fixed

    darnpunk

    (@darnpunk)

    @camilo517 Are you able to elaborate on what you did?

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.