Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter Rookie

    (@alriksson)

    Seems like this issue have been up before. And the issue is filebirds wp-json wont work if you enforce trailing slash. While other works so it must be on your end and should be solved in the core.

    Could you patch a fix to support this?

    I’ve seen this solution before but it should be addressed in the core. And below doesn’t solve the issue.

    if (defined('NJFB_REST_URL')) {
    	add_filter('filebird_json_url', function(){
    		return site_url("wp-json/" . NJFB_REST_URL);
    	});
    }

    Example code for force trailing slash on wordpress urls.

    # Force trailing slash
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_METHOD} GET
    RewriteCond %{REQUEST_URI} !(.*)/$
    RewriteCond %{REQUEST_FILENAME} !\.(gif|jpg|png|jpeg|css|xml|txt|js|php|scss|webp|mp3|avi|wav|mp4|mov)$ [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1/ [L,R=301]
    </IfModule>
    • This reply was modified 4 months, 1 week ago by Rookie.
    Thread Starter Rookie

    (@alriksson)

    I applied a temporary fix to exclude force trailing slash on wp-json folder. But it would be good if a fix was implemented in core to support both for wp-json url and check what should be fetched based on settings. Seems to be sorted on other plugins who use the wp-json.

    For others see row 7.

    # Force trailing slash -- Add just before begin wordpress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_METHOD} GET
    RewriteCond %{REQUEST_URI} !(.*)/$
    RewriteCond %{REQUEST_FILENAME} !\.(gif|jpg|png|jpeg|css|xml|txt|js|php|scss|webp|mp3|avi|wav|mp4|mov)$ [NC]
    # Folders to exclude
    RewriteCond %{REQUEST_URI}  !(wp-json) [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1/ [L,R=301]
    </IfModule>
    Plugin Support Bruce

    (@ninjateamwp)

    Hi @alriksson ,

    Thanks for coming today!
    Please try these 3 solutions to fix the issue:

    1. Update to the latest version
    2. Try to go to permalink settings and click “save” to save permalinks setting:
    https://take.ms/WwyN5
    3. Empty browser cache.

    If none of these helps! Please let us know.

    Kind regards,
    -Bruce-

    • This reply was modified 4 months, 1 week ago by Bruce.
    Thread Starter Rookie

    (@alriksson)

    All this steps have already been tried before reporting this bug. None of this solved the issue.

    Unfortunately none of these helps.

    Plugin Support Bruce

    (@ninjateamwp)

    Hi @alriksson ,

    Sorry but we checked on our side and this issue does not exist, also either one of the fixes mentioned above usually works for many people.

    So for this rare case that you’re reporting, please create a Testing/Staging environment where the issue exist, then contact and schedule a Teamview check with our developes:

    ninjateam.wp@gmail.com

    Thank you!

    Kind regards,
    -Bruce-

    Thread Starter Rookie

    (@alriksson)

    @ninjateamwp Could you try using https://wordpress.org/plugins/hide-my-wp/ on your end. Try free version should be good enough to see if you spot conflicts here.

    Plugin Support Bruce

    (@ninjateamwp)

    Hi @alriksson ,

    Are you suggesting that the referenced plugin might be conflicting with FileBird?

    Have you confirmed that?

    Kind regards,
    -Bruce-

    Thread Starter Rookie

    (@alriksson)

    Yes, but not sure as I couldn’t troubleshoot. Still an issue though, but running on my temporary workaround. But would be nice reduce workarounds if possible.

    Plugin Support Bruce

    (@ninjateamwp)

    Hi @alriksson ,

    We checked and do not see any issue, maybe you could report to that plugin’s author for a fix.
    OR
    please create a Testing/Staging environment where the issue exist, then contact and schedule a Teamview check with our developes:

    ninjateam.wp@gmail.com

    Thank you!

    kind regards,
    -Bruce-

    Thread Starter Rookie

    (@alriksson)

    @ninjateamwp Did you test with a apache environment and forcing trailing slash as my example?

    Plugin Support Bruce

    (@ninjateamwp)

    Hi @alriksson ,

    Sorry, but I’m not able to replicate as such, please feel free to contact us again when you have working environment for testing sake or contact that plugin author.

    Thank you!

    Kind regards,
    -Bruce-

    Thread Starter Rookie

    (@alriksson)

    What stack do you run on your development enviroment? NGNIX? Try local by flywheel you can spin up local apache environment in a couple of seconds.

    It doesn’t seem to be an issue with that plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.