Support » Plugin: WP Statistics » /wp-json/ folder does not exist in my install, and I get a 404 error in console

  • Greetings,

    While inspecting my website pages… in the Console inspector I see this:
    A bad HTTP response code (404) was received when fetching the script.

    <!– Analytics by WP-Statistics v12.6.9 – https://wp-statistics.com/ –>
    <script>var WP_Statistics_http = new XMLHttpRequest();WP_Statistics_http.open(‘GET’, ‘https://www.mydomain.com/subfolder/wp-json/wpstatistics/v1/hit?_=1568322352&_wpnonce=2b7283abdb&wp_statistics_hit_rest=yes&browser=Chrome&platform=Android&version=6.0&referred=https://www.mydomain.com/subfolder/modifier/?pid=23&_wpnonce=b8361d9676&ip=xxx.xxx.xxx.xxx&exclude_reason&ua=Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Mobile Safari/537.36&track_all=1&timestamp=1568307952&search_query&current_page_type=page&current_page_id=23&page_uri=/infolettre-newsletter/&user_id=1’, true);WP_Statistics_http.setRequestHeader(“Content-Type”, “application/json;charset=UTF-8”);WP_Statistics_http.send(null);</script>

    also:
    {“code”:”rest_cookie_invalid_nonce”,”message”:”Le nonce du cookie n\u2019is not valide”,”data”:{“status”:403}}

    Of course, this folder does not exist in my install:
    https://www.mydomain.com/subfolder/wp-json/

    Hope this can help you guys pinpoint a problem…?

    Kindly,

    • This topic was modified 1 month, 1 week ago by  Anticosti.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Mehrshad Darzi

    (@mehrshaddarzi)

    @anticosti
    Hi, do you deactivate WordPress REST API?

    Anticosti

    (@anticosti)

    @mehrshaddarzi
    Thank you for your reply.
    I’ll be able to check and confirm this a little later today, when I’ll be back at my desktop. Maybe I have deactivated Rest API through “Asset CleanUp: Page Speed Booster” plugin?

    Kindly,

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.