Support » Plugin: WP jQuery Lightbox » WP jQuery Lightbox no longer working

  • Resolved wwwolf

    (@wwwolf)


    Sorry to be so vague but I don’t actually know when it stopped – it was working perfectly some time ago, but I haven’t tested it for a while, possibly thru a variety of site WP/plugin updates – only realised it was broken because i wanted to reuse this combo on another site 🙁

    Environment:
    WordPress 4.5.2
    Responsive Pro 1.0.2.0 (+child)
    WP jQuery Lightbox
    WP Gallery Custom Links
    (+ various other plugins incl WordFence)

    I have looked for JS errors, and tried disabling plugins – also tried it both on a Gallery (main use):
    http://arranluxurycottages.com/gallery/
    and on an individual image with rel attribute (added for test purposes):
    http://arranluxurycottages.com/special-offers/
    Nothing.

    HOWEVER… I just compared the code using the Responsive Pro theme and the WP 2016 theme, and it is very different:
    – 2016 uses:
    <figure><div><a><img>
    – Responsive Pro uses:
    <dl><dt><a><img>
    (and adds a substantial srcset attribute to the img)

    is it this different approach to the gallery that’s causing the problem? Thanks!

    https://wordpress.org/plugins/wp-jquery-lightbox/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author ulfben

    (@ulfben)

    is it this different approach to the gallery that’s causing the problem? Thanks!

    No. If you check the source you’ll see that all the image-links are lightboxed properly.

    You have a JavaScript error that breaks the plugin.

    Uncaught Error: Syntax error, unrecognized expression: a[href=#scroll-top]

    Sort that out and you’ll be fine.

    I saw that, but it’s been appearing on lots of sites and never caused a problem before, so I assumed it wasn’t an issue. Doh! Thanks, I’ll try (again) to track that down. I’d tried taking out the on-page code that called it, but that made no difference, so must be in the js itself whether called or not I suppose – not a js programmer at all, so I’ll take it up with the theme developers!

    Thanks 🙂

    Completely mystified – (on a test site) I’ve found the syntax error, fixed it, and uploaded the edited js file, but still keep getting the error message as if I’d changed nothing. Cleared every blasted cache I can find. Giving up for now… 🙁

    FYI I changed:

    jQuery(document).ready(function ($) {
    	$('a[href=#scroll-top]').click(function () {
    		$('html, body').animate({
    			scrollTop: 0
    		}, 'slow');
    		return false;
    	});
    });

    to

    jQuery(document).ready(function ($) {
    	$("a[href='#scroll-top']").click(function () {
    		$('html, body').animate({
    			scrollTop: 0
    		}, 'slow');
    		return false;
    	});
    });

    But, as I said, it still seems to be using an old copy of the script, whatever I do…

    OK – turns out this is a known issue, a theme update is available, it just wasn’t showing up in WP because it’s a ‘pro’ theme not a free one 🙁 Always have so many fewer problems working with free stuff…

    Thanks for your time, once I’ve checked the theme update for any child theme changes, I’m pretty sure that’ll fix it.
    🙂

    Confirmed – all working fine now – thanks for your time.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP jQuery Lightbox no longer working’ is closed to new replies.