Support » Plugin: WP Job Manager » WP Job Manager doesn’t get the listing location info

  • Resolved clementmartineau

    (@clementmartineau)


    Hi there,
    I’m using WP Job Manager plugin to create a map of physical stores. So I created a Google API key and I added it into the plugin settings. This seems to work fine since I see a number of connections to the (Maps Javascript) API on my Google Cloud Console. Plus I see the map with no error displaying on the Listings page of my website.

    BUT, the map is empty, there is no Pin/Store on it. Plus, when I go to one of the Listing page, I added an address in the Listing Data section, I updated the page few times, but in the Custom fields, there is no Location field as it should appear, as if the plugin doesn’t see any address.

    I am working on a local wordpress website using Listable theme. I just spent hours on the web trying to figure it out, if someone please have any idea, i would be really grateful !

Viewing 13 replies - 1 through 13 (of 13 total)
  • He @clementmartineau ,

    Can you share us the example with links to your webste where do you want to do it?

    @kibus90 Hi and thanks for the answer. I am working on a local server so I can’t share any link :/ Maybe I should put it online ?

    @kibus90 I put the site on line, here is the page with the map where the listing should appear : https://www.plumekawaii.com/postes/

    Hi @clementmartineau

    What plugin is generating the map?

    @kibus90 I don’t know, this is the map generated by Listable Theme.

    In the listing edit page, the documentation says that in the curstom fields there shoud be two fileds, geolocation_lat and geolocation_long but there’s not. It seems WP Job Manager doesn’t take the address I put in the page. I made it simple, I just wrote a city. The address, I have to write it in the Place field of Data Fields, or in another Custom Fields ?

    Thanks for helping

    @kibus90 I tried to add these two custom fields manually and the pin appears to the map. So since it is supposed to be generated automatically, what is the name of the custom field where I should add the normal address ?

    Because WP Job Manager does not genereting these two fields because of missing Google Map API. Also these fields are stored as custom fields (not as meta data like all rest information in WP Job Manager). πŸ™‚

    @kibus90 Yes sure I did, otherwise, the map wouldn’t even appear, And I see the connections in the Google Console. So this seems to work fine. I even already regenerated 3 times an API key, but still nothing.

    I really don’t understand where the problem is..

    The field where I have to enter the address is the Location field in the Job Data, right ?

    @clementmartineau

    I saw that map was working 5 minuts ago… What did you brake again? πŸ˜€

    Yes, just fill in the “Location’ field and this should work.

    @kibus90 I didn’t break anything, I told you I added manually the two custom fields geolocation_lat and geolocation_long with some coordinates I found on Google. But I’m not going to add manually some coordinates on every single listing so I deleted them.

    If I just add the address on the Location field as requested, all the custom fields about location that should appear automatically are not there. The Plugin doesn’t create these custom fields. πŸ™ Why ?

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi!

    BUT, the map is empty, there is no Pin/Store on it.

    I do have to point out that the map is not something that is part of the WPJM plugin, it’s in the theme, so I can’t troubleshoot it.

    there is no Location field as it should appear, as if the plugin doesn’t see any address.

    The field where I have to enter the address is the Location field in the Job Data, right ?

    How are you submitting job listings? Are you doing it from the job submission form on the front-end of the site? Or are you adding them via wp-admin?

    Plugin Contributor Richard Archambault

    (@richardmtl)

    I’m marking this thread as Resolved as it’s been more than a month since the last reply. If you still need help, please do reply again and mark the thread as Unresolved!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.