Support » Requests and Feedback » WP issues with PHP 8.0 (imagick and in general)

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Dion

    (@diondesigns)

    I wanted to add that if you update the imagick 3.4.4 PECL source package with the following five files from the https://github.com/Imagick/imagick master branch:

    php_imagick_defs.h
    imagick.c
    imagick_class.c
    imagick_helpers.c
    imagickkernel_class.c

    you will be able to compile imagick 3.4.4 for PHP 8.0. One hopes this is quickly migrated to PECL and to the various package managers/sites.

    I noticed imagick is missing on DreamHost.

    MJ

    (@prmyapps)

    i just upgraded to WP 5.8 and now the Site Health Status screen says

    “One or more recommended modules are missing – Performance
    – The optional module, imagick, is not installed, or has been disabled.”

    I use a Dreamhost shared server running PHP 8.0, and Dreamhost told me
    “We suggest you to change your PHP version to 7.4 as it includes Imagick.”

    I see in the WP support forums that this imagick problem has been around for over 1 year. Should I downgrade to PHP 7.4 and hope this error goes away, or is the error too incidental to WP and I should just ignore it?

    Thank you for help,
    -mj lee

    zeevg

    (@zeevg)

    Ditto the above … should I switch back to PHP 7.4 on Dreamhost for my WordPress site?

    MJ

    (@prmyapps)

    @zeevg On Dreamhost, my website is now on WP 5.8.1 and PHP 8.0 FastCGI. I no longer get the Site Health Status performance message about imagick. So I guess this problem is fixed?

    • This reply was modified 10 months ago by MJ. Reason: added @zeevg
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP issues with PHP 8.0 (imagick and in general)’ is closed to new replies.