WP Issues today ... (9 posts)

  1. randomfrequency
    Posted 3 years ago #

    In an attempt to fix a wp core problem... I replaced files from the "pucblic" area and discovered this was not the right fix.

    I created more problems with the hooks in WP.

    Fatal error: Call to undefined function get_front_page_template() in /home2/superno7/public_html/wp-includes/template-loader.php on line 26

    What is the next course of action?

    oh and you can thank

    the next generation of misfits for hacking my site in the first place...

  2. Boston WP
    Posted 3 years ago #

    Switch to another template and see if that works.

  3. Gtantra
    Posted 3 years ago #

    Whats the URL ?

  4. randomfrequency
    Posted 3 years ago #

    Hi guys, thanks...

    I uh , can loginto the wp site but

    when I press the theme in the dashboard

    I get

    Fatal error: Class 'WP_Theme' not found in /home2/superno7/public_html/wp-includes/theme.php on line 69

    I am looking at my backups but it may be a month old...

  5. randomfrequency
    Posted 3 years ago #

    Are we having fun yet, I am...
    idk... I like to restore these WP files but I cannot forsee which
    of the
    core needs

    the status of the site is diminishing ...
    which is funny...

    I never seen a website deteriorate into not

    functioning before...

    I am sure there is another guy/gurl experiencing the same issue...

  6. randomfrequency
    Posted 3 years ago #

    my url http://www.supernova512.com/

    for every action there is an equal or opposite reaction

    in the subject of things in motion, physics

  7. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Delete the wp-admin and wp-includes folders. DO NOT delete the wp-content folder. Download a fresh copy of 3.4.1 and upload wp-admin and wp-includes directories to the server.

    If you were hacked you also need to check out these links.
    Follow information in these links.


  8. randomfrequency
    Posted 3 years ago #

    chaos before order ? right?

    or was it

    order before chaos?

    or was it a flash of light


  9. StandardExcellence
    Posted 3 years ago #

    Just as a note - I have the same problem (symptom) but mine is the result of moving WordPress from 1 domain to another on the same server. I also tried to put the site on the root of the domain but leave WordPress in a folder. I've had all sorts of database reference issues which I think are resolved, but now I'm getting the blank site problem.

    I deleted wp-includes and wp-admin, and when I re-uploaded from a fresh install, I got the "WordPress needs to update the database" message. It tried to do its thing then had the same error as before.

    Fatal error: Class 'WP_Theme' not found in /privateserverinformation.../wp-includes/theme.php on line 106

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.