Support » Fixing WordPress » WP is adding (bad) markup to my pages

  • I have the latest WordPress running, and I’m editing pages without the WYSIWYG editor. Despite the page html being correctly saved into the database, when the page is served, wordpress is adding </p> to my output!

    I’ve done the idiot checks: it’s not a ‘rendered source’- it’s direct source as read by the validator. I have flushed my cache, disabled my plugins and checked with another browser.

    I’m worried- why is WordPress tampering with my pages? Trying to be clever and adding things?

Viewing 1 replies (of 1 total)
  • I managed to fix this problem by commenting out add_filter('the_content', 'wpautop');
    in the default_filters file-
    I guess the question is, why does WordPress apply so many filters to raw code? Should it be applying any?

Viewing 1 replies (of 1 total)
  • The topic ‘WP is adding (bad) markup to my pages’ is closed to new replies.