WordPress.org

Forums

Frontend Uploader
[resolved] Wp installed in Sub-directory - success landing page url wrong (9 posts)

  1. bob27707
    Member
    Posted 1 year ago #

    I have a simple setup with my uploader installed on a page:
    http://www.24x7secure.com/sites/?page_id=99

    After uploading the file, the success page tries to go to:
    http://www.24x7secure.com/sites/sites/?page_id=99&response=fu-sent

    It should go here:
    http://www.24x7secure.com/sites/?page_id=99&response=fu-sent

    Why is it inserting the extra subdirectory 'sites' and how do i make this not happen?

    https://wordpress.org/plugins/frontend-uploader/

    [Moderator Note: No bumping, thank you.]

  2. Rinat Khaziev
    Member
    Plugin Author

    Posted 1 year ago #

    I have never tested it with sub-directory installs. I'll check and let you know.

  3. bob27707
    Member
    Posted 1 year ago #

    Thanks. I think it's a simple edit to the code, I just can't find the right place.

  4. Rinat Khaziev
    Member
    Plugin Author

    Posted 1 year ago #

    In the mean time you can add success_page shortcode parameter so it looks something like this:
    [fu-upload-form success_page='http://www.24x7secure.com/sites/?page_id=99']

    That'll force plugin to redirect to that page on upload.

  5. bob27707
    Member
    Posted 1 year ago #

    No the redirect doesn't work either because it assumes you are installed in the root. I'm installed in a directory.

    Any other ideas?

    If I look at the plugin code it might have something to do with admin_url but I don't want to break it so I don't know what to try there.

  6. bob27707
    Member
    Posted 1 year ago #

    Not certain how this got marked resolved. I still have the problem and I'm still looking for a solution.

  7. lupetu
    Member
    Posted 1 year ago #

    I've had the same problem.
    I don't know if this is a robust fix, but it worked for me:

    Plugins->Editor->Frontend Uploader
    Edit frontend-uploader/frontend-uploader.php by removing this line:

    // We need full url, not just query part
    			$redirect_url = home_url( $redirect_url );
  8. bob27707
    Member
    Posted 1 year ago #

    Thanks lupetu, that fixed it. I'm up and running with this plugin thanks to you! Cool!

  9. Rinat Khaziev
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    I just released 0.7.6 which should handle redirects properly.

    So something like
    [fu-upload-form success_page="http://mysite.dev/redirect-here/"]
    should work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Frontend Uploader
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic