Support » Localhost Installs » WP Install – “Waiting for localhost” (XAMPP)

  • Resolved drbobjr

    (@drbobjr)


    I’m trying to install XAMPP and WordPress on my local Windows 10 PC. XAMPP install went smoothly when I used port 81 instead of 80 (competes with Microsoft.) Apache and MySQL startup fine. No problem setting up new database with MyPHPAdmin. I start the WordPress install with localhost:81/wordpress and up comes the WordPress installation script. I select English, enter the database name user name and password. I change localhost to localhost:81, then click Submit. It freezes with “Waiting for localhost” in the lower left-hand corner of my browser. What am I missing? Thanks so much!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello Dr. Bob jr,

    In order to create a local WordPress site, you will need to set up a web server software (Apache), PHP, and MySQL on your computer.

    This is a very lengthy process but I just came across a very detailed tutorial/ explanation on how to fix this problem.

    https://www.wpbeginner.com/wp-tutorials/how-to-create-a-local-wordpress-site-using-xampp/

    Hopefully this helps,

    Warmest greetings,

    Nelson

    Dion

    (@diondesigns)

    The database host should be localhost and not localhost:81. Port 81 is only for the webserver. The database uses a different port that does not need to be specified unless it is different than the default of 3306.

    Nelson & Dion, Thank you for your quick replies. While they didn’t deal directly with the specific port issue I was having, they lead me to a different path. I gave up trying to support both Apache and MS IIS and went with the flow. I shut down MS IIS and completely scorched the XAMPP and WP installs (my third) and started again with everything completely standard. It worked. I never did get to the root of the issue, but I can say that the standard install doesn’t work with IIS running. Thanks again for your help! – Bob

    My pleasure Bob, Happy we were able to point you in the right direction.

    I think in database host you don’t need to specify the port with :81. You would have directly mentioned the localhost in database host. btw I think issue is already resolved 🙂

    Thanks, Arvind. Specifying the port as :81 did word sporadically. But the real issue was trying to run MS IIS and Apache at the same time. Both wanted that port. It was much easier to just shut down MS IIS and let Apache ru nit’s default settings.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP Install – “Waiting for localhost” (XAMPP)’ is closed to new replies.