Support » Fixing WordPress » wp-includes/pluggable.php on line 866 can not solve it at all

  • Resolved kesepian

    (@kesepian)


    Hello!
    My website was moved from another server, but the URL address is the same.
    I edit wp-config with database, user, password, and the site is working.

    Still, I can not access the wp-admin page. I get this error:

    Warning: Cannot modify header information – headers already sent by (output started at /home/xxx/public_html/xsite/wp-includes/class-wp-theme.php:1) in /home/xxx/public_html/xsite/wp-includes/pluggable.php on line 866.

    I have been reading for hours the forums and Googled it, and followed but nothing!
    Any help would be really appreciated.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Reupload a fresh copy of the wp-admin folder.

    I reuploaded the wp-admin folder, and the error persists.
    I will wait for your next suggestions.
    Thank you.

    Did you follow my link above and check that?

    Do you have any debugging turned on? In your wp-config.php file you can add this code toward the bottom

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    I had this error a few weeks ago and it was something in a custom file I was writing and didn’t have anything to do with pluggable.php

    Seacoast Web Design, I already check for spaces and everything is OK. No spaces.

    johnbhartley, after putting your code, the wp-admin page goes blank. Is this a good thing?

    Looking forward for your answers.
    Thank you.

    You’ll need to find your debug.log file. It should be in the wp-content directory. Take a look at that and you should be able to see what the issue is. If not, take out the code and troubleshoot again. Are you using custom post types or custom plugins?

    I can not see the debug.log file (using Filezilla).
    I am not using anyc custom plugins. I do not know what is a custom post type.
    All I use is: pagenavi, xcloner backup and restore, wp-cumulus, picasna, dbk backup.

    I’d recommend removing the code I told you to add and deactivating the most recently added plugins until it goes away. Other than that I’m not sure.

    I removed the code and the wp-admin page displays again: Warning: Cannot modify header information – headers already sent by (output started at /home/xxx/public_html/xsite/wp-includes/class-wp-theme.php:1) in /home/xxx/public_html/xsite/wp-includes/pluggable.php on line 866.

    The last plugin I installed was xcloner. I would deactivate it, but I am not sure how. (renaming its folder from plugins folder?).

    @kesepian: Delete the xclone plugin folder via FTP. You don’t need to rename the whole plugins folder (in order to force deactivate all plugins), unless deleting the one plugin doesn’t work.

    I deleted the xcloner plugin folder via FTP.
    No change, the same error persists.

    Force deacvtiactivate all plugins. Reupload wp-includes.

    I managed to solve my problem by using an old backup made when everything went OK (right before installing xcloner). Everything works like a charm.

    Thank you: songdogtech, johnbhartley, Seacoast Web Design.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘wp-includes/pluggable.php on line 866 can not solve it at all’ is closed to new replies.