Support » Fixing WordPress » wp-includes/nav.php – Trying to get property of non-object from wp

  • Resolved nashproductions

    (@nashproductions)


    Hello – absolutely dumb-founded by this random error-code that has appeared after no major alterations to the site

    It can be found here

    The error reads:
    Notice: Trying to get property of non-object in /hermes/bosoraweb073/b2912/nf.olivernat/public_html/e-ternity/wp-includes/nav-menu.php on line 591

    Any ideas would b e greatly appreciated – could not find any solutions to similar issues online – and very limited similar issues were even out there!

    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • Try pasting this code in wp-config.php at the end.

    error_reporting(E_ERROR);

    Hi Rajesh, tried that.. no change. Should I be looking for something different now?

    Can you paste the last few lines of your wp-config.php file (Not the entire file)?

    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    ?>
    error_reporting(E_ERROR);

    should I put it in the ?> maybe ??

    require_once(ABSPATH . 'wp-settings.php');
    ?>
    error_reporting(E_ERROR);

    Should be:

    require_once(ABSPATH . 'wp-settings.php');
    error_reporting(E_ERROR);
    ?>

    okay, it reads like that now

    Hey Rajesh – any ideas ? Was I supposed to see something change with that added?

    I will take that as a no… 🙁

    Still in no resolution land, if anyone else has any ideas!!

    Found the resolution!

    I replaced my line 591 in wp-includes nav.php
    $original_title = $original_object->post_title;

    with
    $original_title = isset( $original_object->post_title ) ? $original_object->post_title : '';

    THANK HEAVENS

    Hey nashproductions you are a god send, you have no idea how grateful I am for the fix that you posted. Just started wordpress, only done a few pages of my new site to log in today and see same error.

    Did not have a clue what happened or how to fix. Thank you so much for posting your fix worked perfectly for my problem. You are a genius…thank you so so much…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wp-includes/nav.php – Trying to get property of non-object from wp’ is closed to new replies.