Support » Fixing WordPress » wp-includes folder erased during update process

  • I’ve developed a website for a client and was ready to launch (move to root directory). I selected the update link with my host’s control panel last night to update from 3.5 to 3.5.1, which resulted in a lengthy error message. When I checked on my files and folders in the file manager, I noticed that the wp-includes folder was no longer there.

    I didn’t have the folder backed up but tried to download WP and upload the original wp-includes folder, to no avail.

    I have the database and stylesheet backed up. Is it easier to just reinstall wordpress and then overwrite the stylesheet and database?

    The host’s tech support staff is proving to be absolutely useless on the issue. I didn’t pick them and have urged client to look elsewhere for better host.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    – running the upgrade manually via wp-admin/upgrade.php

    esmi, thank you for your assistance.

    I’ve been able to restore the folders and have attempted to move wordpress to the root directory. I’m not sure what’s missing but the site is not being configured as it should. I took the following steps:

    1. Moved all files and folders from /wordpress/ subdirectory to root folder (httpdocs).
    2. Exported database in myPHPAdmin and updated all instances of url to reflect new location in root.

    Would be grateful if you or anyone could take a look.

    Thank you.

    Did you carry out all of the steps in Moving_WordPress?

    I got to updating the permalinks settings and then got the following message at the bottom of the permalinks screen:

    “If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.”

    Where do I find the .htaccess file? I cannot find anything with that name in the root directory where I’ve moved all of the core WP files.

    Thank you again for your assistance.

    Still not sure about the htaccess file. For the sake of keeping things moving along, I’ve tried to update my database by replacing all instances (1408 total) of with

    When I drop the previous database in its entirety and import the updated database, my website reverts to the original theme (making it seem as though all image files and stylesheets are not where they should be, and content is completely gone.

    What the heck is going on?

    You may not actually have an .htaccess file yet but do check that your FTP client is configured to show all files. .htaccess files are often hidden by default. If you definitely do not have an .htaccess file, you will need to create one using a plain text editor, add the lines given to you by WP and finally upload the file to your domain’s root folder.

    Thank you. In plain English, what does an .htaccess file do?

    Google is your friend…

    I’ve been all over Google. Unfortunately, I am a designer and not a developer. All of the issues I’ve been having with this have fried my brain and I’m not understanding much developer-speak at this point.

    Should I post in another forum or look elsewhere for more direct assistance? Thank you for your time thus far.

    If you want support on general server issues/functionality, you would be better off posting in a server forum, yes. We only deal with WordPress-specific issues here.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘wp-includes folder erased during update process’ is closed to new replies.