[resolved] wp-includes errors in 3.5.1 upgrade (3 posts)

  1. ecass7
    Posted 3 years ago #

    I've just downloaded the 3.5.1 zip file and followed the instructions (http://codex.wordpress.org/Updating_WordPress) for the manual upgrade (automatic upgrade wouldn't work for me, even with php5). When I upload the wp-includes directory I get the following message from net2ftp:

    Warning: ftp_mkdir() [function.ftp-mkdir]: 5745 Kbytes used (0%) - authorized: 1536000 Kb in /home/mainhost/public_html/file-manager/includes/filesystem.inc.php on line 986

    For reference, I have replaced wp-admin and wp-includes directories and manually replaced the necessary files in wp-content. I have also renamed my current theme to include "-old" as per esmi's instructions in various other posts addressing users with similar problems. Unfortunately, none of those resolutions seem to work for me. I have tried reuploading multiple times, but when I try to access the login for my site I get this message:

    Fatal error: Call to a member function register_handler() on a non-object in /home/a2297728/public_html/wordpress/wp-includes/media.php on line 953

    When I look to the media.php file lines 951-954 it reads:
    function wp_embed_register_handler( $id, $regex, $callback, $priority = 10 ) {
    global $wp_embed;
    $wp_embed->register_handler( $id, $regex, $callback, $priority );

    I'm fairly new to php so I really have no clue at all what is going wrong. My site is: http://www.charlottedupre.webatu.com/wordpress

    I'd really appreciate any help provided, thanks!!

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    You seem to have a corrupt or faulty upload. Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. ecass7
    Posted 3 years ago #

    After a fresh download of 3.5.1, deleting all files and folders (except wp-content) and then uploading the new copies I still get this error message:

    Warning: ftp_mkdir() [function.ftp-mkdir]: 5772 Kbytes used (0%) - authorized: 1536000 Kb in /home/mainhost/public_html/file-manager/includes/filesystem.inc.php on line 986

    BUT! The upgrade still worked! Thanks a bunch for the help and quick reply :)

Topic Closed

This topic has been closed to new replies.

About this Topic