Support » Plugin: BackWPup - WordPress Backup Plugin » WP Http Error: cURL error 60: SSL certificate problem: self signed certificate

  • Resolved decarvalhoaa

    (@decarvalhoaa)


    Have I been running backwpup for some years and I have recently come across the following issue.

    On my test system, a local virtual machine using a self-signed certificate, can’t make any backup after having upgraded php-curl to the latest release. The debug information below, indicates the problem is created because I’m using a self-signed certificated.

    I tried changing php.ini and added curl.cainfo=”/abs/path/to/self-signed/cert.pem” and effectively solved the issue, but WP core and plugin updates stopped working.

    I tried also adding the following filter to disable ssl verification to no avail:

    add_filter( 'backwpup_cacert_bundle', '__return_false' );

    I tried as well the wordpress filter but it seems it is ignored by the plugin:

    add_filter( 'https_local_ssl_verify', '__return_false' );

    Can you please let me know whether there is another way to overcome this problem?

    DEBUG INFO:

    WordPress version: 4.7.3
    BackWPup version: 3.4.3
    PHP version: 5.6.31  (64bit)
    MySQL version: 10.0.32-MariaDB
    cURL version: 7.40.0
    cURL SSL version: OpenSSL/1.0.2k
    WP-Cron url: https://tlc-dev/wp-cron.php
    Server self connect: Not expected HTTP response:
    WP Http Error: cURL error 60: SSL certificate problem: self signed certificate
    
    Document root: /var/www/tlc-dev
    Temp folder: /var/www/tlc-dev/wp-content/uploads/backwpup-43c6d9-temp/
    Log folder: /var/www/tlc-dev/wp-content/uploads/backwpup-43c6d9-logs/
    Server: Apache/2.4.10 (Mageia) OpenSSL/1.0.2k PHP/5.6.31
    Operating System: Linux
    PHP SAPI: apache2handler
    Current PHP user: apache
    Maximum execution time: 30 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: On
    CHMOD Dir: 0755
    Server Time: 20:55
    Blog Time: 21:55
    Blog Timezone: 
    Blog Time offset: 1 hours
    Blog language: en-US
    MySQL Client encoding: utf8
    PHP Memory limit: 268435456
    WP memory limit: 128M
    WP maximum memory limit: 256M
    Memory in use: 27.50 MB
    Loaded PHP Extensions:: Core, Reflection, SPL, SimpleXML, Zend OPcache, apache2handler, ctype, curl, date, dom, ereg, filter, ftp, gd, gettext, hash, iconv, imagick, json, libxml, mbstring, mysql, mysqli, mysqlnd, openssl, pcre, posix, session, soap, standard, sysvsem, sysvshm, timezonedb, tokenizer, xml, xmlreader, xmlwriter, zlib
    
Viewing 7 replies - 1 through 7 (of 7 total)
  • By the way, I upgraded WP to 4.8.2 and confirm the same behavior as described above.

    Plugin Support Andreas W.

    (@aweissinpsyde)

    Hi decarvalhoaa,

    it’s possible to try another free SSL certificate like https://letsencrypt.org/getting-started/

    Thank you

    Hi

    Thanks you for the quick feedback.
    Yes i can try that, but not before next weekend. I will post back if i’m successful overcoming the issue or otherwise.

    Can you explain meanwhile what is the intended use of the filter ‘backwpup_cacert_bundle’?

    Cheers
    A

    Plugin Support duongcuong96

    (@duongcuong96)

    @decarvalhoaa,
    is your problem got resolved?

    Plugin Support duongcuong96

    (@duongcuong96)

    @decarvalhoaa,since we haven’t heard back from you, I’m going to mark it as resolved.
    If you’re still having problems, feel free to let us know ;),

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support 😀
    https://wordpress.org/support/plugin/backwpup/reviews/

    Hi there,

    apologies for not responding back. I know that it is now near 4 month later but the issue persists. Let me know if you prefer that I open a new issue.

    The suggestion to use free SSL certificate like Let’s Encrypt doesn’t help since the issue is on my development station (without a public domain name – it’s just localhost) and Industry rules completely forbid publicly trusted CAs like Let’s Encrypt from issuing certificates for internal domain names.
    I can’t also make use of the following filter to disable ssl verification:

    add_filter( 'backwpup_cacert_bundle', '__return_false' );

    I tried as well the wordpress filter but it seems it is ignored by the plugin:

    add_filter( 'https_local_ssl_verify', '__return_false' );

    I’m my production server everything work perfectly since I’m using a public domain name.

    The strange part is that before version 3.4.3 this was working also on my local development station.

    To fix this, use the http_request_args filter. What you want to do is force sslverify to false.

    In my class, I use this:

    
    add_filter('http_request_args', array($this, 'curlArgs'));
    

    Then you can see the method here.

    
        public function curlArgs($r, $url) {
            $r['sslverify'] = false;
            return $r;
        }
    

    WordPress uses the WP_Http object for requests so you just want to override the SSL Check since you know this is safe (as it’s your local dev) I have the same issues and this solved it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WP Http Error: cURL error 60: SSL certificate problem: self signed certificate’ is closed to new replies.