Support » Plugin: WP Help » WP Help incompatible with PHP7

  • webelaine

    (@wpgirl369)


    Our host is upgrading our server to enable PHP7, so we ran compatibility checks with the PHP Compatibility Checker plugin (https://wordpress.org/plugins/php-compatibility-checker/) to make sure our sites will function properly after the upgrade.

    Unfortunately, WP Help throws the following warning about one file:

    FILE: (redacted)/wp-content/plugins/wp-help/lib/requirements-check.php\
    ——————————————————————————————————————————————————————————\
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES\
    ——————————————————————————————————————————————————————————\
    40 | WARNING | Method name “CWS_WP_Help_Requirements_Check::__php_at_least” is discouraged; PHP has reserved all method names with a double underscore prefix for future use\
    59 | WARNING | Method name “CWS_WP_Help_Requirements_Check::__wp_at_least” is discouraged; PHP has reserved all method names with a double underscore prefix for future use\
    ——————————————————————————————————————————————————————————\

    We are happy with WP Help and would love to see these warnings resolved so that we can continue to use it after we upgrade to PHP7.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘WP Help incompatible with PHP7’ is closed to new replies.