SSL Grins
[resolved] WP Grins SSL not working for some reason (26 posts)

  1. Ryan Hellyer
    Posted 3 years ago #


    Any idea why WP Grins SSL wouldn't be working on my site?

    The CSS is loading, the JS is loading, jQuery is being called correctly it seems and I have an ID of #comment applied to the textarea.

    It looks like it should work, but it .... just doesn't :(


  2. Does your theme have wp_head() in there?

    Also what other plugins are you running?

  3. Ryan Hellyer
    Posted 3 years ago #

    Thanks for the reply.

    Yep, the theme has wp_head() in there, that's what's outputting the CSS and JS ;)

    Plugins in use are:
    1 Cookies for Comments
    2 Google Plus Feed Widget
    3 Redirection
    4 Search & Replace

    Plus nine custom plugins. The only one which uses JS is a colorbox plugin, but disabling that didn't seem to help.

  4. I installed all those locally and it's still working on the Twenty Eleven theme. All I can think is that it's a theme issue, now. That's WP Paintbrush?

  5. Ryan Hellyer
    Posted 3 years ago #

    That's an alpha version of the WP Paintbrush theme with an alpha version of a plugin which allows for different HTML code in the WP Paintbrush theme.

    It's also a multi-site network using SSL for the admin panel.

    I'm assuming this is just a JavaScript problem of some sort. If my understanding is correct, the plugin just uses some JavaScript to dynamically add some HTML near the #comments tag so the only plugins which should be affecting it would be ones which added JavaScript to it.

  6. Ryan Hellyer
    Posted 3 years ago #

    It's definitely not a theme issue. I've temporarily switched to Twenty Eleven and sill seeing the same issue ... http://ryanhellyer.net/2011/10/02/group-trip-to-idaburn/

  7. (Theme issues came to mind since themes can include JS.)

    MultiSite or MultiNetwork? I'm using this on Ipstenu.org, which is multisite (which you knew). Is there anything in your error log?

  8. Ryan Hellyer
    Posted 3 years ago #

    Multi-site with SSL.

    I was hoping you would respond with "You FOOL! You missed this really stupidly obvious thing you twit!". Then I'd go fix it in a matter of seconds. No such luck I guess.

    I might leave this for a week or two and get back to it when I have time to dive in an figure out what's going on.

    Thanks for your assistance so far though.

  9. And it's just SSL for administration. I checked on SSL and non-SSL, 3.3 and 3.2.1, and it's working... Augh. Hate this.

    Two tests.

    1) There's a wp-grins-ssl.js.dev file. Swap that with the .js file and see if that helps. The .js is just compressed, but it can't hurt to test.

    2) Change wp-grins-ssl.php line 98 to this:
    'Ajax_Url' => admin_url('admin-ajax.php', 'https'),

    See what happens?

  10. Ryan Hellyer
    Posted 3 years ago #

    Neither of those worked unfortunately :(

  11. Ryan Hellyer
    Posted 3 years ago #

    I've managed to track it down to the inline JS:

    /* <![CDATA[ */
    var wpgrinsssl = {"Ajax_Url":"https:\/\/ryanhellyer.net\/wp-admin\/admin-ajax.php","LOCATION":"admin"};
    /* ]]> */

    The URL used for the admin-ajax.php file doesn't work with the one used on my live site, but if I changed it to my local dev versions URL (which is not using SSL or sub-domains/domain mapping) it works just fine.

  12. Interesting. Where is your ajax file then, if not /wp-admin/admin-ajax.php?

    That's just pulled from 'Ajax_Url' => admin_url('admin-ajax.php', $schema_ssl), though maybe I should see if there's a front end version to call in wp-includes...

  13. Ryan Hellyer
    Posted 3 years ago #

    No, the file is there, it just appears to be not working the way it should be.

    You can visit it at the following URL and see that it spits out the expected -1 output ... http://ryanhellyer.net/wp-admin/admin-ajax.php

  14. And it works as https://ryanhellyer.net/wp-admin/admin-ajax.php too...

    Okay, looking at mine:

    <script type='text/javascript'>
    /* <![CDATA[ */
    var wpgrinsssl = {"Ajax_Url":"http:\/\/test.ipstenu.org\/wp-admin\/admin-ajax.php","LOCATION":"admin"};
    /* ]]> */

    But that works just fine.... Wait. Mine is http, no S, even on sites where I'm using SSL.

  15. Ryan Hellyer
    Posted 3 years ago #

    I've tried with and without the "S" but to no avail. I'm kinda stumped here.

    I need to try disabling ALL of my plugins and step through bit by bit until I can fix it, but not keen on doing that right now as it would require shutting of a bunch of network activated plugins in the process and some of those are a little frail and may actually break some of the sites on the network in the process (need to fix those bugs up but don't have time right now).

    Thankfully I'm not in a hurry to use the plugin, so I'll probably leave this a few weeks before tackling it again.

    Thanks for your help so far. It's much appreciated.

  16. Try doing it locally? The "nine custom plugins" are hard to debug ;)

  17. Ryan Hellyer
    Posted 3 years ago #

    I tried locally and it worked fine.

    I'm assuming it has something to do with the fact that my live install uses sub-domains/domain mapping or that it's using SSL. They're the only differences I can think of ... or I made a mistake and haven't replicated my live site in some other way.

  18. I use subdomains and SSL on ipstenu.org, though NOT domain mapping.

  19. Ryan Hellyer
    Posted 3 years ago #

    I'll try a site without a mapped domain and see if that helps.

  20. Ryan Hellyer
    Posted 3 years ago #

    That was it :)


    Um ... any ideas on where the problem might lie?

    I'm a bit stumped on this one. If the plugin were using the sub-domain and the main part of the site was using it's own domain, I'd have put it down to a cross-domain AJAX request not working. But it's using the mapped domain for the AJAX call anyway, so I don't think can be it.

    Or perhaps we should just call on the Rennicks aka "multi-site gurus" for assistance?

    This isn't a big deal if I can't use the plugin. I was mostly just installing it since you had made it so wanted to make use of your handywork, but I'd be quite keen to at least figure out what is causing this. It seems like it should work.

    At least it can be narrowed down to the domain mapping causing the issue now.

  21. Well monkey butter, bug crap. Yeah, I'm turning on the bat signal for RonAndrea.

  22. Ron Rennick
    MultiSite Guru
    Posted 3 years ago #

    Is it Donncha's DM plugin? Are you running the admin area on the unmapped subdomain?

    If so, the admin-ajax requested gets redirected to the unmapped subdomain at which point it does become an issue of cross domain ajax.

  23. Ron Rennick
    MultiSite Guru
    Posted 3 years ago #

    Also, if it is Donncha's, give the dev version a try. I added some code a couple months back for that redirect issue but haven't had any feedback on it yet.

  24. Ryan Hellyer
    Posted 3 years ago #

    Thanks Ron.

    Yeah it is Donncha's plugin. I'll give the dev version a try and let you know if it fixed the problem or not.

  25. Ron Rennick
    MultiSite Guru
    Posted 3 years ago #

    If you still have the issue, I added cross domain ajax support here: http://plugins.trac.wordpress.org/browser/document-repository/trunk/document-repository.php?rev=429101#L85

  26. Ryan Hellyer
    Posted 3 years ago #

    Bingo! That did it :)

    I was running a much older version of the domain mapping plugin which was used in the mu-plugins folder so not sure if the current stable one would have worked or not, but your trunk version seems fine for sure.

    Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SSL Grins
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic