Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » WP Forms lite & Recaptcha

  • Resolved dfounde

    (@dfounde)


    I have 3 forms on my website.
    https://thenortherndad.co.uk/contact-me
    https://thenortherndad.co.uk/media-kit
    https://thenortherndad.co.uk/guest-writers

    i use wp forms lite with recaptcha v3 and also use:
    <div class=”cmplz-blocked-content-notice cmplz-accept-cookies cmplz-wpforms”
    style=”text-align: left; cursor: pointer;”>
    Click here to accept reCaptcha cookies before sending the form.
    </div>

    since the latest update of complianz, the forms no longer submit, i get a google recaptcha failure. everything worked perfect until the new update of complianz.

    if i disable the wp forms integration, the forms work fine.

    whats changed in the latest version to prevent this working?

    no errors in console, nothing to indicate the cause of the error.

    I have disabled the integration for WP Forms

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @dfounde,

    I will have a look, we didn’t change the integration, maybe WP Forms changed something at their end.

    regards Aert

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @dfounde,

    I tried here; https://s-q4plqlwn458dl.eu1.wpsandbox.org/

    Seems to work.

    I have reCaptcha v3 and the latest versions. Did anything change besides this on your website?

    regards Aert

    Thread Starter dfounde

    (@dfounde)

    nothing has changed.

    other than an update from complianz and 2 days later an update from wp forms.

    if i disable the integration it works fine.

    i can re-enable to integration on my site for you to check if you want?

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @dfounde,

    Yes, please.

    Did you check the question in the wizard, under Cookies – Integrations – “Do you want to block reCAPTCHA before consent, and when consent is revoked?”

    This should be set to “Yes”.

    regards Aert

    Thread Starter dfounde

    (@dfounde)

    Hi @aahulsebos
    My cache took a while to clear.

    It appears the issue is with WP forms.

    With the integration turned off the issue is still there.

    This ticket can be closed and I’ll raise the issue with WP Forms.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP Forms lite & Recaptcha’ is closed to new replies.