Support » Fixing WordPress » WP Folder loads slowly

  • holcomb17

    (@holcomb17)


    My problem is interesting. If you navigate to https://kernelwiki.com — the root of the site, the page loads quickly.

    If however, you click on the Penguin from the main site or navigate directly to:
    https://kernelwiki.com/wiki — (wiki is where all the standalone WordPress files are), then the page takes a long time to load.

    I have only one plugin installed.

    The site is running on:
    Raspberry Pi – Buster
    4GB RAM
    Quad Core
    Linux, Apache, MariaDB, PHP 7

    Can anyone tell me what I might be doing wrong? Or why when navigating to the actual WordPress directory directly, it takes so long to load?

    Thank you in advance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    I use two plugins to speed up sites — autoptimize, to combine and minify CSS, HTML, and JS and Comet Cache, to cache the resulting pages.

    holcomb17

    (@holcomb17)

    Hey Steve,

    Thanks for the reply. I’ll try those out. That said, I’m using Redis at the moment (which I thought would speed up the website), but apparently it isn’t working as intended.

    I think this might be an Apache routing issue — but I can’t tell. I’m pretty positive that the html looks correct:
    <a href="wiki"><img src="Tux.png" /></a>
    — “wiki” is the name of the wordpress installation folder. Should it be configured differently at all?

    With the two plugins you mentioned, is there anything specific needed to configure them or do I just install them and be good to go?

    • This reply was modified 11 months ago by holcomb17.
    • This reply was modified 11 months ago by holcomb17.
    • This reply was modified 11 months ago by holcomb17.
    • This reply was modified 11 months ago by holcomb17.
    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    It has nothing to do, IMHO, with apache routing.

    Look at the options for those plugins. You need to enable stuff in autoptimize. Comet Cache is pretty much “click the first box and go”, though it’s worth exploring the options.

    holcomb17

    (@holcomb17)

    Steve it looks like CometCache is working at the moment. I will try this out and see how things go.

    Thank you for your suggestions and help!

    Regards.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    It definitely helps

    <!-- Cache File Version Salt:       n/a -->
    
    <!-- Cache File URL:                https://kernelwiki.com/wiki/kernel-overview-1/ -->
    <!-- Cache File Path:               /cache/comet-cache/cache/https/kernelwiki-com/wiki/kernel-overview-1.html -->
    
    <!-- Cache File Generated Via:      HTTP request -->
    <!-- Cache File Generated On:       Nov 18th, 2019 @ 9:21 pm UTC -->
    <!-- Cache File Generated In:       11.26359 seconds -->
    
    <!-- Cache File Expires On:         Nov 25th, 2019 @ 9:21 pm UTC -->
    <!-- Cache File Auto-Rebuild On:    Nov 25th, 2019 @ 9:21 pm UTC -->
    
    <!-- Loaded via Cache On:    Nov 18th, 2019 @ 9:21 pm UTC -->
    <!-- Loaded via Cache In:    0.00333 seconds -->
    holcomb17

    (@holcomb17)

    Yup,

    I see the same results. Thanks Steve!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP Folder loads slowly’ is closed to new replies.