Support » Fixing WordPress » WP error message > error:14090086:SSL

  • Resolved Qualiweaver

    (@qualiweaver)


    Hi all:

    Since yesterday, one of my self-hosted WordPress modules (the one which is not access-restricted to my own IP using HtAccessProtectIP) is experiencing the following SSL issue (I’m using Let’s Encrypt on a self-hosted OVH server):

    Error message which appears in the « WordPress Events and News » widget of the Dashboard:

    « RSS Error: WP HTTP Error: cURL error 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed. »

    Error message which interrupts all attempts at updating themes and plugins:

    « An error occurred while updating [name of the plugin]: Download failed. cURL error 60: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed. »

    As I could not find any other error message (either on my OVH dashboard or through such SSL scanners as https://globalsign.ssllabs.com) confirming the above, I reported the incident to my web hosting provider, but in case it has something to do with that specific WordPress website (of which all components were up-to-date prior to that error), I also need to do if someone has already encountered the same issue, and if yes, what can be done about this at user level.

    With thanks and regards,

    Daniela Berndt

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    Did you resolve your problem? I have exactly the same error on my WP for 3 days and my website is also on OVH server. If you found solution, please share information how to fix it, beacuse I cannot update any plugins and wp core too…

    Greetings,
    Mat

    Hi Mat,

    I just solved the problem by phone with my support desk, which confirmed that the problem is due to the environment of execution declared by default next to the PHP settings on the user’s OVH dashboard:

    Try the following:
    – log in to your OVH admin dashboard,
    – on the left admin bar, go to your hosting plans,
    – select the domain name affected by the issue,
    – next to the PHP settings (if the latter are set to v7.0), click the button which enables to modify the configuration,
    – if your declared environment is set to « legacy », switch it over to « stable »,
    – confirm the modification,
    – log in to your WordPress module and perform all pending updates.

    My customer advocate further confirmed upon request that this SSL error message is of the generic type, and that the above problem resolution can therefore be transmitted to the WordPress forums.

    Regards,

    Daniela

    Hi Daniela

    You are amazing! I owe you big beer! Now everything works fine on my website. Thank you for your instruction.

    Best Greetings,
    Mat

    Thanks for the feedback, I’m glad it helped you as well.

    I’m afraid I’ll have to share the beer with my customer advocate!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP error message > error:14090086:SSL’ is closed to new replies.