Support » Localhost Installs » wp-env start issue

  • Resolved martinabaz

    (@martinabaz)


    I am trying to run my webpage from local host but I am getting this issue:

    × Error: spawn git ENOENT
        at ChildProcess._handle.onexit (node:internal/child_process:283:19)
        at onErrorNT (node:internal/child_process:476:16)
        at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
    GitError: Error: spawn git ENOENT
        at ChildProcess._handle.onexit (node:internal/child_process:283:19)
        at onErrorNT (node:internal/child_process:476:16)
        at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
        at Object.action (C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:1261:25)
        at PluginStore.exec (C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:1296:29)
        at C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:1661:43
        at new Promise (<anonymous>)
        at GitExecutorChain.handleTaskData (C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:1659:16)
        at GitExecutorChain.<anonymous> (C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:1643:44)
        at Generator.next (<anonymous>)
        at fulfilled (C:\Users\marti\AppData\Roaming\npm\node_modules\@wordpress\env\node_modules\simple-git\dist\cjs\index.js:55:24) {
      task: {
        commands: [
          'clone',
          '--depth=1',
          '--no-single-branch',
          'https://github.com/WordPress/WordPress.git',
          'C:\\Users\\marti\\.wp-env\\fc6be23cf5e91ade3c451d7ecd48b8e8\\WordPress'
        ],
        format: 'utf-8',
        parser: [Function: parser]
      }
    }

    What should I do?

Viewing 1 replies (of 1 total)
  • Thread Starter martinabaz

    (@martinabaz)

    after full 4hours trying to solve and asking the question at the end – I found out that I needed to change the terminal setting within Docker

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.