WordPress.org

Forums

WP Ecommerce shipping not working (1 post)

  1. Ariana
    Member
    Posted 5 years ago #

    When a customer puts items in their shopping cart and then goes to checkout, the shipping charge is not always adding on to their total. I have both the table rate and flat rate shipping modules set up, and the shipping charges are calculating/being stated correctly at checkout, but they are just not being added on to the total.
    Ex. With a subtotal of $40.00, and customer selects table rate charge (which lists at $8.00), the tax is $3.50, and the total cost is coming up as $43.50 instead of $51.50.

    I am having another issue as well during the occasional chance the shipping actually does work.
    I use Authorize.net as my payment gateway. When a customer submits their order (with shipping charge actually added on to their total), Authorize.net is not calculating the shipping in the Total Amount, so the amount processed on a customer's credit card is the total less the shipping charge. The receipt that a customer receives via email from me shows a different amount than the receipt received by Authorize.net. I called Authorize.net and they say it is a shopping cart problem (an error with the code maybe?) where somehow the shipping rate is not being calculated in the Total Amount. The Total Amount is what is processed by Authorize.net.
    What can I do to fix this problem??? I've eaten a lot of shipping costs.

Topic Closed

This topic has been closed to new replies.

About this Topic