Support » Plugin: Easy WP SMTP » WP Easy SMTP Won’t Save Settings

  • Resolved timothydungan

    (@timothydungan)


    I’ve installed the plugin, but when I go to the setup page and click the SAVE button, nothing happens. It just reverts to same thing and I still get the same message that it needs to be set up. I don’t even know where it should be saving the settings in the database so I can go in and manually add them directly.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, can you carry out a test. Disable all of your other plugins except this one. Then try to save your settings again? Does this work? If it doesn’t, how much memory is allocated to your site by your host?

    Regards

    I can confirm. This is occurring on the newest build. I rolled back to version Version 1.2.5 and it works. I disabled all plugins and still wouldn’t work.

    Plugin Support mbrsolution

    (@mbrsolution)

    @nickalert, thank you for reporting this. The developers will investigate further this issue.

    Thank you

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Gentlemen, just installed a fresh copy of WordPress (version 4.9.1) and a current version of Easy WP SMTP plugin (which is 1.3.1 at the moment) and the settings are saving just fine for me.

    I did noticed a little bug that the plugin isn’t setting some default values upon activation, but this is not directly related to the issues you’re having.

    @timothydungan, please try following mbrsolution’s advice and let us know if that helped.

    Thread Starter timothydungan

    (@timothydungan)

    Tried disabling all other plugins. Didn’t help. Still won’t save. The PHP memory limit is currently set to 256 MB while the total RAM is 3 GB.

    Thread Starter timothydungan

    (@timothydungan)

    Okay, this is silly. The temporary work-around fix for this would be to manually place the proper values directly into the database. This can work until whatever is blocking the save can be worked out. Does anyone with a working version of this plugin know exactly where in the database it stores the information and how?

    Plugin Support mbrsolution

    (@mbrsolution)

    @timothydungan, you should check your server log files. See if they can reveal any important information about this issue. If this does not help you, try speaking to your host support staff.

    I am sure this is due to a server settings configuration.

    Regards.

    • This reply was modified 4 years, 6 months ago by mbrsolution.

    I can confirm that the settings are not saving for me either. We have 20+ sites on a multisite network that all have the SMTP settings configured and working correctly. We created a new site this week and havent been able to save SMTP settings.
    Latest version of WP and Plugin.

    Thanks
    Steven

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi @steven_gardner.

    Is it possible to get admin access for your site so I could have a look?

    Email me alexanderfoxc at gmail.com if that can be organized.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    I just tested the latest version of the plugin in Multisite. Even though Multisite is not officially supported, I’ve activated it via Network and manually configured it on each site and everything is working as expected, so this is not Multisite incompatibility issue I first thought of.

    If we can figure out which is thing is causing the conflict, I can alter the plugin so it would be working fine. I can’t see the enemy, therefore can’t fight it 🙂 Need your help in that, gentlemen.

    @steven_gardner, can you try to disable all plugins but Easy WP SMTP and switch to some default WP theme like Twenty Seventeen and see if it works? The credentials you provided don’t have enough permissions to do so.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    I think I might have figured out why the settings aren’t saving.

    Steven provided me the access to his website and I noticed part of plugin Settings interface is not shown – Test Email box is absent, also Advanced Settings box is not fully displayed. A nonce field was cut off as well, that’s why settings weren’t saved since nonce check was failing. I’m not sure what exactly is causing this cut-off, but I have re-done the Settings interface to use separate tabs for boxes and hopefully this should fix the issue.

    I made a test build, could you please install it on your site and test it? https://desertfox.me/miniserv/_public/easy-wp-smtp_1.3.2-testing.zip

    • This reply was modified 4 years, 6 months ago by Alexander C..
    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    I have also figured why the interface is being cut off.

    The plugin requires php-mbstring extension to be installed on the server. If it’s not there, it won’t be able to operate properly.

    Please make sure php-mbsting extension is installed.

    I’ll try to find a way for plugin to not rely on it if possible. Or at least to display a warning message saying it’s required.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Ok, made necessary changes to the plugin. Now it will no longer fail to display Settings interface if php mbstring extension is not installed on the server.

    Here’s the test build https://desertfox.me/miniserv/_public/easy-wp-smtp_1.3.2-testing.zip

    If you can confirm it’s working, a new version of the plugin will be released shortly.

    Hi Alexander,

    The latest update seems to have done the trick. Thanks for all your hard work and persistence.

    Sorry I couldn’t feedback earlier as I was away on a family trip for the holidays.

    Many Thanks
    Steven

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hey Steven, no problem. And actually thank YOU for providing me the access and helping out to track down the issue 🙂

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘WP Easy SMTP Won’t Save Settings’ is closed to new replies.