The WP e-Commerce plug-in does not specify that it has been tested in version 3.2.1 in the readme.txt file.
Requires at least: 3.0 Tested up to: 3.2
Has it or hasn't it?
If it has, why is the "Tested up to:" line only reflecting version 3.2?
The information listed on the WordPress Plugin page says its compatible up to version 3.2.1 but the readme.txt file doesn't state that it has been tested in version 3.2.1 - so I'm wondering how you know it is compatible with the version 3.2.1 of WordPress if it hasn't been tested in version 3.2.1?