WordPress.org

Forums

Yoast SEO
wp e-commerce single product URL ending / 404 error (2 posts)

  1. Dongo Bongo
    Member
    Posted 2 years ago #

    Hi, I'm using this SEO plugin together with wp e-commerce and I have some problems indexing the single product pages in google.

    When I explore a single product URL ending in / through google webmaster tools, it shows 404, page not found. But by exploring the same page without / google bot can find it correctly. So basically it is not indexing my single product pages because of that.

    -single product pages without / redirect to the version ending in /
    -both versions display correctly in all browsers (the redirect works and of course displays only the / ended verion).
    -settings > permalinks is set to /%postname%/
    -.htaccess is
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    So this is a very bad issue, products don't get indexed, website does not exist. Is this a SEO Yoast issue or exclusively WP E-commerce? Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. genzki
    Member
    Posted 2 years ago #

    Try install the Permalink Editor no other changes to be done, you just need to activate it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic