Support » Plugin: AnyFont » WP e-Commerce Category page is showing an AnyFont error

  • Initial setup:
    WP: 3.4.2
    Theme: Atahualpa 3.7.9
    Plugins: AnyFont 2.2.3, Magic Zoom 5.9.26, WP e-Commerce 3.8.9

    Hello all at the forum!

    I have a weird situation when I installed and set up WP e-commerce (from GetShopped) on a website with an Atahualpa theme.
    On the category pages, only one product image shows, the rest of the product details show and below I get (I think an AnyFont)error code showing (see SCREENSHOT).
    All other shop pages such as individual items look absolutely fine.

    I changed back to TwentyEleven theme where the error code is not showing (see SCREENSHOT ), so one could assume it has something to do with my Atahualpa Theme. I have reported the issue there, but so far we have found no solution yet.

    As most of the error code showing seems to be AnyFont, I assumed this would disappear when deactivating it, however, other error code was still showing, as well as only one product image showing (see SCREENSHOT ).

    I then tried deactivating MagicZoom too, which made no change in the error code.

    Moving back to Twenty Eleven with plugins (apart from WP e-commerce) deactivated showed everything showing without error code and both product images.

    Updating my Atahualpa Theme to 3.7.9 made no difference.

    TWO WEEKS LATER: I had a little breakthrough: updated WPEC from version to 3.8.9 which was a major update.
    This fixed the Category title issue which is awesome, I also fixed the extra image issue, however, the AnyFont error code is still showing 🙁

    I was working on a different e-commerce site this week where the error was showing also, but I was hoping it might disappear when upgrading to Gold Cart and getting a Grid View. Unfortunately, the error code is still showing: LINK
    It is really odd how it is showing in Firebug :

    <div class="product_grid_display group">
    <div class="product_grid_item product_view_9" style="width: 146px;">
    <div class="product_grid_item product_view_52" style="width: 146px;">
    <div class="product_grid_item product_view_69" style="width: 146px;">
    @font-face{font-family: 'Cambria'; bla bla bla more error code here!}

    It is residing within the div class “product_grid_display group”. Previously in my other site, it was within a p tag and when in configure excerpts I said to strip the p class, after saving it was still showing the error code, just not within the p tag.
    It seems to be really persistent and I cannot find a CSS selector to make is display:none, nor can I find anywhere in the AnyFont settings to not show any error code.
    I am still baffled too, that it is not showing in TwentyEleven theme meaning it must clash somewhere with Atahualpa too?

    I have also written to WPEC as it seems to be the combination of the three causing this error code to show 🙁

Viewing 1 replies (of 1 total)
  • Update:

    So far no reply from either, so I’ve decided to manually use @font-face instead and everything in my local site is now working as it should.
    Although the incompatibility of the combo of plugins with ATA is not solved, at least there is a work-around.

    For anyone interested, this is the code I used in HTML/CSS inserts (after moving the font files from wp-content/uploads/fonts to my own fonts folder in the root):

    font-family: Cambria;
    	src: url('/fonts/cambria.ttf'),
        	url('/fonts/cambria.eot'); /* IE9 */
    font-family: Calibri;
    	src: url('/fonts/calibri.ttf'),
        	url('/fonts/calibri.eot'); /* IE9 */

    Then where-ever I wanted to change the font ie body/menu etc, I went to the corresponding ATA area ie Body/Text and Links or Page Menu/Category Menu and changed the font to either font-family: “Calibri”, Verdana, tahoma, arial, sans-serif or 17px “Cambria”, “Times New Roman”, Times, serif

    I will mark this thread as solved!

Viewing 1 replies (of 1 total)
  • The topic ‘WP e-Commerce Category page is showing an AnyFont error’ is closed to new replies.