Support » Fixing WordPress » WP-dTree 3.4.1 incorrect detect WordPress 2.6.2 version

  • In WordPress site with WP-dTree 3.4.1 activated plugin have error:

    [Table ‘wordpressbase.wp_post2cat’ doesn’t exist]
    SELECT wp_posts.ID AS id, wp_posts.post_title AS title, wp_post2cat.category_id AS catid FROM wp_posts, wp_post2cat WHERE wp_post2cat.post_id = wp_posts.ID AND wp_posts.post_status = ‘publish’ AND wp_posts.ID != 0 AND wp_posts.post_type = ‘post’ ORDER BY wp_posts.post_date DESC

    Incorrect detect version WordPress in WP-dTree plugin 3.4.1 in file wp-dtree_cat-functions.php in string 66:

    if((float)$wp_version < 2.3) {

    To fix this error, must change this string:

    if($wp_version < ‘2.3’) {

    This receipt on russian language – http://stmd.ru/archives/404

    PS: 404 – just coincidence 🙂

Viewing 1 replies (of 1 total)
  • Thanks for taking your time and helping out! This bug might explain quite a few error reports I’ve gotten.

    I’ve applied the fix and bumped the version number so people will get the update notification soon.

    Note to self: In PHP when comparing two numerical strings, they are compared as integers.

Viewing 1 replies (of 1 total)
  • The topic ‘WP-dTree 3.4.1 incorrect detect WordPress 2.6.2 version’ is closed to new replies.