Support » Installing WordPress » WP doesn’t import

  • I’ve got WP 2.0.4 installed on my computer and and a Movable Type export file. I’ve used this file to import my old blog to a blog and I haven’t had any problems, but when I try to do the same in my WP it doesn’t import nothing.

    That’s weird, because in the import process WP asks me for the user I want to assign the posts to and it tells me at the end “All done. Have fun!”, like everything were done, but none of the posts that should be imported appear listed over the all done final message.

    I’ve got Apache 2.2.3, PHP 5.1.6 and MySQL 4.1 installed and all the compatibility problems apeared during their installations were solved. I use PHPMyAdmin and I ton’t have any problems with it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Wanna cheat?

    I’m clueless on the MT import. However, if you already imported it to a wp.COM blog, why not import from the wp.COM blog to your new blog?

    This plugin enables your new blog to import the WXR format:

    I’ve tried it and with the same results: WP doesn’t imports nothing, but it thinks it has done all the work well, so I think the problem is other. It could be a problem with the database, but I don’t know (that’s why I’m asking 😛 ). The problem must be mine (my configuration or something) and not of the import methods.

    Anyway, this kind of plugins are the ones that make WP as great as it is.

    I’m actually having the exact same problem.

    I was originally attempting to import to WordPress from Diaryland, so I used the Rhino exporter to get it to Movable Type format. And now I have this perfectly fine MT format export file… and I’ve been able to successfully import it to my WordPress.COM blog, but not WordPress on my server.

    It imports perfectly, then tells me to go “have fun”, but when I go to the Manage tab, it lists the months (back to 2001), but won’t show the entries. Apparently, I still have no entries.

    Anyone have any ideas? This is getting frustrating.

    sofrlowi: Actually it sounds like a plugin is limiting your viewing. Go into phpmyadmin and check to see if there are any posts in your wp_posts table

    SELECT COUNT(*) FROM wp_posts

    Especially since it’s showing months, my gut says your posts were imported fine. Just make sure your plugins, particularly any having to do with post listings, aren’t nuking your viewing.

    Hmm, I have Live Press and a cross-WP importer plugin (the one mentioned before) installed. I don’t think the problem is with Live Press but I’ll delete them all just to be safe (except the backup).

    EDIT: I’m not sure what you mean by selecting count(*)… what am I supposed to be looking for in wp_posts?

    And I deleted all plugins except the backup and I still have the problem. 🙁

    Oh, I got myself together and can see that I have all my posts there. Problem might be that they’re all set to be drafts, but shouldn’t they still appear?

    How can I set them all to publish instead of draft?

    Thanks for handling my noob questions. 🙂

    I’ve checked my database with PHPMyAdmin and the post’s table (#_posts) is empty. completly empty. I’ve tried to uninstall WP, delete the DB and reinstall WP again without any change or additional plugin, only the setup process, the first login and import. But the problem persists. My problem must be another.

    I’m having the same problem as Ryback importing from MT in wordpress 2.0.4.

    The import process seems to finish (I get the “have fun!” message) but there are no entries in wordpress and I don’t see any entries in my db.

    Ryback & traustik, i get he same problem trying tio import from my worpress.ord account to my hosted account.

    It says it imports but the import screed shows no imported entries.

    Anyone else see this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WP doesn’t import’ is closed to new replies.