WordPress.org

Support

Support » How-To and Troubleshooting » WP doesn't display content text on Chrome

WP doesn't display content text on Chrome

  • Hello, I had a WordPress site using wp version 3.3, it seems that in firefox doesn’t have any problems but when I browse it using Google Chrome, the content text didn’t showing up anymore. It last years and days, our site doesn’t had any problem browsing in Chrome, we are just wondering when we discovered it today in browsing it in chrome.

    Some of the font-family that we were using were from google fonts.

    Does anyone have an idea about our case?
    any help will be appreciated, thanks in advance…

Viewing 15 replies - 16 through 30 (of 32 total)
  • The control-f5 may be the issue because you’re generating a hard refresh, circumnavigating the 304 response.

    Would it help if I posted a link to a screenshot?

    Took me less than 1 minute of browsing on Chrome OS x to generate it:

    http://www.itinerantangler.com/temp/screenshot.png

    Compare with:

    http://www.itinerantangler.com/blog/board/forums/

    Ok people, here’s a potential temporary fix for you.

    This issue seems to be a problem with Chrome’s handing of browser cacheing, specifically related to 304 responses from your server, which tell Chrome nothing has changed with a file.

    Until Chrome fixes this problem, one thing you can do is turn off browser cacheing, which may slow your site down somewhat. (My server was fast enough not to cause too many issues but this is probably not a good long-term fix).

    To turn off browser caching, modify the header.php file in your theme, adding the following adjacent to the other < meta > tags:

    <meta http-equiv="cache-control" content="max-age=0" />
    <meta http-equiv="cache-control" content="no-cache" />
    <meta http-equiv="expires" content="0" />
    <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
    <meta http-equiv="pragma" content="no-cache" />

    That will instruct the browser not to cache the files, but instead to re-load all files (200 Request) with each refresh. Again, this may slow your site some but at least your users will see the content.

    If anyone has any suggestions on making this Chrome-only so that non-Chrome users don’t lose cacheing, I am all ears.

    Zach

    The fix didn’t work. It appeared to with Chrome OS x but the problem remains in Chrome for Windows (on a completely different computer).

    Sorry guys, it doesn’t sound like we’re going to get help on this from WordPress and I am out of ideas.

    Zach

    Hey, some good news. If you download Google Chrome Canary, which is their Beta build, the problem has been resolved. This is pretty clearly a Chrome issue with its current build.

    I’m also having this problem on a WordPress site I’m working on. Some notes:

    – Only happens in current version of Google Chrome, not Chrome Canary. So it seems to be a Chrome bug. But it happens on OS X and Windows.

    – Only happens on custom fonts (these are ones I downloaded from Font Squirrel)

    – Only seen it on this site, not any other site?

    Zach I can’t reproduce it on your site, did you find a fix?

    No fix, rubious, and it’s still happening for me in Chrome Vanilla but not Chrome Canary.

    It’s clearly a Chrome bug.

    Zach, I can’t make it happen on your site – strange.

    I found this topic on the Google forums in which someone has posted some jQuery that fixes the bug (albeit in a pretty hackish way):

    function reloadStylesheets() {
        var queryString = '?reload=' + new Date().getTime();
        $('link[rel="stylesheet"]').each(function () {
            this.href = this.href.replace(/\?.*|$/, queryString);
        });
    }
    
    if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){
     reloadStylesheets() ;
    }

    It works for me, I just hope I don’t have to keep it forever.

    I’m confused why this is happening on the site I’m working on but not any other sites?

    It’s a timing thing rubious. I think you need to browse around long enough to trigger a 302 unchanged response from the server when you refresh a page you visited earlier. On my server I think the trigger time is 5 minutes, so you would just need to spend some time on one of these sites to start triggering it.

    Zach

    Hi Zach,

    I’ve found my problem – I think it’s your problem too!

    If you update the FitVids script to the latest version you’ll find the problem is now fixed: https://github.com/davatron5000/FitVids.js

    It was that all along, we are both using it (and someone else who posted a link above).

    Glad that is finally sorted – and it explains why it was only happening on this site and not other sites I’m working on.. first time I used the FitVids script.

    Shaun

    ptinning4

    I still did not fixed it, it seems when you refresh the site, the text will disappear…

    my previous thread on the issues I was encountering http://wordpress.org/support/topic/site-text-missing-on-chrome – related to same topic on this page thought I would back-link the pages for everyone…Ok everyone I found the answer after reading some more online forums here on WordPress and on Google and by doing some trouble shooting of my own. Every one kept thinking it was a cache issue as I thought the same thing as well, which is partially correct, but it has to do with the 304 return. That’s why upon reload sometimes it works and sometimes it doesn’t. The funny thing about this issue is that it’s a simple fix. So simple everyone is going to scream when they find out how to resolve the issue for now. The issue is Google fonts. If you have Google Fonts or even a different font-face file loaded into your theme then you will have this issue currently in Chrome. It is a bug with the current version of Google Chrome. I have read that if you download the new beta Chrome Canary the issue has been resolved. To fix the issue simply change your text to a web safe font. I changed ours to standard Arial font and everything now works perfect and loads perfect. Also remember if you are using any inline font-style short codes you will need to change the font-style as well to a web safe font. Once everyone has changed over to the new Chrome or if Google fixes this bug will I then change back to custom fonts. Also if you are using a theme make sure to check all your misc-typography fonts and widget fonts for those will be effected as well. I hope this help you all!!! Thanks everyone for your continued support. If it wasn’t for people like us writing on forums to help others do I really think WordPress or the Web-design world would be where it is today…

    Hi jkovach,

    It’s not Google fonts that are the cause of the issue, it’s an old version of FitVids. I had a look at your site and you are using FitVids 1.0 (in this file: http://dealershiptracking.com/wp-content/themes/canvas/includes/js/third-party.js?ver=3.8.1 ) if you update that to the latest version (currently 1.1) it will fix your issue.

    https://github.com/davatron5000/FitVids.js

    I know this is the issue because I’m not using Google Fonts but had the same issue, and as soon as I updated FitVids the issue was fixed.

    Give it a go, and you can keep your fonts!

    Shaun

    Well I updated the FitVids to 1.1

    Rubious

    and it seems to have worked… Thanks for letting me know!!!
    If you have any insight as to why this update fix the issue please let me know…I am nerdy like that and must have more knowledge

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘WP doesn't display content text on Chrome’ is closed to new replies.