WordPress.org

Support

Support » How-To and Troubleshooting » WP doesn't display content text on Chrome

WP doesn't display content text on Chrome

  • Hello, I had a WordPress site using wp version 3.3, it seems that in firefox doesn’t have any problems but when I browse it using Google Chrome, the content text didn’t showing up anymore. It last years and days, our site doesn’t had any problem browsing in Chrome, we are just wondering when we discovered it today in browsing it in chrome.

    Some of the font-family that we were using were from google fonts.

    Does anyone have an idea about our case?
    any help will be appreciated, thanks in advance…

Viewing 15 replies - 1 through 15 (of 32 total)
  • Can you post the link to your site?

    I can see your content in chrome.

    “In the spirit of the season, Geranium Homes and Pace Credit Union purchased 300 pairs of Olympic Red Mittens to support Canadian athletes. The mittens have been donated to York Region shelters on behalf of Geranium and our homebuyers.

    THANK YOU for making our communities such a great place to live. Season’s Greetings to you and your family from all of us at Geranium Homes!”

    and the other stuff. Have you installed anything on your browser? maybe cleaning the cache will fix the problem.

    I didn’t install anything in my chrome, I have check the site in several computers, but in in 1st load in chrome, the text wouldn’t showing up, but when you try to inspect element, the text will show up… I have cleaned my cache already but same problem in chrome… 🙁

    I got the same problem.. does anyone has an idea what this might be?

    I also have this exact same problem. Chrome must have changed something recently for us all to be experiencing this. I also cleaned my cache in chrome and it still is happening. Hopefully someone will have an answer soon…

    pythonidea
    I also see your content in my chrome. Did you fix this? I’m desperate. Please help if possible.

    I posted too quick and I should’ve just tried to fix it myself.

    I was using Istok Web or Istok font and for some reason I don’t think that font traveled over to the new version of Google Chrome. So I changed the font to a comparable one and… Voila! I’m back in business. Hope this helps you guys, too

    I have the exact same problem on my site (http://www.rasierer-tests.com/). I tried several different fonts now, but this didnt help.

    Any other ideas what I could try?

    This is happening on my site as well and seems to be related to Chrome failing to ignore something in the 304-no change response from the server. Firefox and other browsers do ignore this bugged setting, which I think has to do with content-level or something like that. I’ll try to find more details and consolidate, but this is a serious bug in the new WordPress build with respect to Chrome users.

    Here’s more info in a non-wordpress context:

    http://stackoverflow.com/questions/15767917/page-refresh-causes-css-to-be-ignored

    And here’s a good explanation from that thread:

    It turns out this has to do with chrome handling the 304 response.

    Chrome asks for content and receives a 304 response saying it is not modified.

    When IIS returns a 304 response it has content-type in it. Chrome doesn’t ignore the content type and looks and sees that the content type has been changed since IIS just returns the default type chrome thinks the file is no longer a stylesheet and doesn’t load it.

    So in order to fix this we made it reload stylesheets everytime. I have not figured out an easy way to modify the 304 response so that it does not include content-type.

    Here is the google issue https://code.google.com/p/chromium/issues/detail?id=246875

    It looks to me like in the most recent WordPress build something changed with the 304 content-type setting. I am not sure how we can modify that but the solution for now seems to be making our servers not return a content-type setting of any kind on the 304 response. That may be a server-side issue.

    Moderator kmessinger

    @kmessinger

    For all of those who posted with a link to your sites, I see them all in Chrome. I fail to see how this is a Chrome problem, a server problem or a WordPress problem.

    If you continue to have a problem please start your own thread as per http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    That way we can try and help each of you on an individual basis. WordPress 3.8x has been downloaded 22,483,117 times with no widespread errors reported in Chrome

    The problem occurs on refresh, not on the initial load. Your ability to see the site on the initial load is not reproducing the bug because you’re not spending enough time there navigating around for Chrome to need to send a refresh request and generate a 304 response.

    This is independent 5X reporting on the same issue. It’s a bug.

    Moderator kmessinger

    @kmessinger

    First, I click on many links and used cntrl F5 multiple times with no problems. Second 5X an issue does not mean a bug. I see you have posted individually so I’ll move to that post.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘WP doesn't display content text on Chrome’ is closed to new replies.
Skip to toolbar