WordPress.org

Ready to get started?Download WordPress

Forums

[closed] WP doesn't display content text on Chrome (33 posts)

  1. pythonidea
    Member
    Posted 1 year ago #

    Hello, I had a WordPress site using wp version 3.3, it seems that in firefox doesn't have any problems but when I browse it using Google Chrome, the content text didn't showing up anymore. It last years and days, our site doesn't had any problem browsing in Chrome, we are just wondering when we discovered it today in browsing it in chrome.

    Some of the font-family that we were using were from google fonts.

    Does anyone have an idea about our case?
    any help will be appreciated, thanks in advance...

  2. Forensica Digital
    Member
    Posted 1 year ago #

    Can you post the link to your site?

  3. pythonidea
    Member
    Posted 1 year ago #

  4. Forensica Digital
    Member
    Posted 1 year ago #

    I can see your content in chrome.

    "In the spirit of the season, Geranium Homes and Pace Credit Union purchased 300 pairs of Olympic Red Mittens to support Canadian athletes. The mittens have been donated to York Region shelters on behalf of Geranium and our homebuyers.

    THANK YOU for making our communities such a great place to live. Season’s Greetings to you and your family from all of us at Geranium Homes!"

    and the other stuff. Have you installed anything on your browser? maybe cleaning the cache will fix the problem.

  5. pythonidea
    Member
    Posted 1 year ago #

    I didn't install anything in my chrome, I have check the site in several computers, but in in 1st load in chrome, the text wouldn't showing up, but when you try to inspect element, the text will show up... I have cleaned my cache already but same problem in chrome... :(

  6. irernst
    Member
    Posted 1 year ago #

    I got the same problem.. does anyone has an idea what this might be?

  7. ptinning4
    Member
    Posted 1 year ago #

    I also have this exact same problem. Chrome must have changed something recently for us all to be experiencing this. I also cleaned my cache in chrome and it still is happening. Hopefully someone will have an answer soon...

  8. ptinning4
    Member
    Posted 1 year ago #

  9. ptinning4
    Member
    Posted 1 year ago #

    pythonidea
    I also see your content in my chrome. Did you fix this? I'm desperate. Please help if possible.

  10. ptinning4
    Member
    Posted 1 year ago #

    I posted too quick and I should've just tried to fix it myself.

    I was using Istok Web or Istok font and for some reason I don't think that font traveled over to the new version of Google Chrome. So I changed the font to a comparable one and... Voila! I'm back in business. Hope this helps you guys, too

  11. Rasierer-Test
    Member
    Posted 1 year ago #

    I have the exact same problem on my site (http://www.rasierer-tests.com/). I tried several different fonts now, but this didnt help.

    Any other ideas what I could try?

  12. ZachMatthews
    Member
    Posted 1 year ago #

    This is happening on my site as well and seems to be related to Chrome failing to ignore something in the 304-no change response from the server. Firefox and other browsers do ignore this bugged setting, which I think has to do with content-level or something like that. I'll try to find more details and consolidate, but this is a serious bug in the new WordPress build with respect to Chrome users.

  13. ZachMatthews
    Member
    Posted 1 year ago #

    Here's more info in a non-wordpress context:

    http://stackoverflow.com/questions/15767917/page-refresh-causes-css-to-be-ignored

    And here's a good explanation from that thread:

    It turns out this has to do with chrome handling the 304 response.

    Chrome asks for content and receives a 304 response saying it is not modified.

    When IIS returns a 304 response it has content-type in it. Chrome doesn't ignore the content type and looks and sees that the content type has been changed since IIS just returns the default type chrome thinks the file is no longer a stylesheet and doesn't load it.

    So in order to fix this we made it reload stylesheets everytime. I have not figured out an easy way to modify the 304 response so that it does not include content-type.

    Here is the google issue https://code.google.com/p/chromium/issues/detail?id=246875

    It looks to me like in the most recent WordPress build something changed with the 304 content-type setting. I am not sure how we can modify that but the solution for now seems to be making our servers not return a content-type setting of any kind on the 304 response. That may be a server-side issue.

  14. kmessinger
    Moderator
    Posted 1 year ago #

    For all of those who posted with a link to your sites, I see them all in Chrome. I fail to see how this is a Chrome problem, a server problem or a WordPress problem.

    If you continue to have a problem please start your own thread as per http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    That way we can try and help each of you on an individual basis. WordPress 3.8x has been downloaded 22,483,117 times with no widespread errors reported in Chrome

  15. ZachMatthews
    Member
    Posted 1 year ago #

    The problem occurs on refresh, not on the initial load. Your ability to see the site on the initial load is not reproducing the bug because you're not spending enough time there navigating around for Chrome to need to send a refresh request and generate a 304 response.

    This is independent 5X reporting on the same issue. It's a bug.

  16. kmessinger
    Moderator
    Posted 1 year ago #

    First, I click on many links and used cntrl F5 multiple times with no problems. Second 5X an issue does not mean a bug. I see you have posted individually so I'll move to that post.

  17. ZachMatthews
    Member
    Posted 1 year ago #

    The control-f5 may be the issue because you're generating a hard refresh, circumnavigating the 304 response.

  18. ZachMatthews
    Member
    Posted 1 year ago #

    Would it help if I posted a link to a screenshot?

    Took me less than 1 minute of browsing on Chrome OS x to generate it:

    http://www.itinerantangler.com/temp/screenshot.png

    Compare with:

    http://www.itinerantangler.com/blog/board/forums/

  19. ZachMatthews
    Member
    Posted 1 year ago #

    Ok people, here's a potential temporary fix for you.

    This issue seems to be a problem with Chrome's handing of browser cacheing, specifically related to 304 responses from your server, which tell Chrome nothing has changed with a file.

    Until Chrome fixes this problem, one thing you can do is turn off browser cacheing, which may slow your site down somewhat. (My server was fast enough not to cause too many issues but this is probably not a good long-term fix).

    To turn off browser caching, modify the header.php file in your theme, adding the following adjacent to the other < meta > tags:

    <meta http-equiv="cache-control" content="max-age=0" />
    <meta http-equiv="cache-control" content="no-cache" />
    <meta http-equiv="expires" content="0" />
    <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
    <meta http-equiv="pragma" content="no-cache" />

    That will instruct the browser not to cache the files, but instead to re-load all files (200 Request) with each refresh. Again, this may slow your site some but at least your users will see the content.

    If anyone has any suggestions on making this Chrome-only so that non-Chrome users don't lose cacheing, I am all ears.

    Zach

  20. ZachMatthews
    Member
    Posted 1 year ago #

    The fix didn't work. It appeared to with Chrome OS x but the problem remains in Chrome for Windows (on a completely different computer).

    Sorry guys, it doesn't sound like we're going to get help on this from WordPress and I am out of ideas.

    Zach

  21. ZachMatthews
    Member
    Posted 1 year ago #

    Hey, some good news. If you download Google Chrome Canary, which is their Beta build, the problem has been resolved. This is pretty clearly a Chrome issue with its current build.

  22. rubious
    Member
    Posted 1 year ago #

    I'm also having this problem on a WordPress site I'm working on. Some notes:

    - Only happens in current version of Google Chrome, not Chrome Canary. So it seems to be a Chrome bug. But it happens on OS X and Windows.

    - Only happens on custom fonts (these are ones I downloaded from Font Squirrel)

    - Only seen it on this site, not any other site?

  23. rubious
    Member
    Posted 1 year ago #

    Zach I can't reproduce it on your site, did you find a fix?

  24. ZachMatthews
    Member
    Posted 1 year ago #

    No fix, rubious, and it's still happening for me in Chrome Vanilla but not Chrome Canary.

    It's clearly a Chrome bug.

  25. rubious
    Member
    Posted 1 year ago #

    Zach, I can't make it happen on your site - strange.

    I found this topic on the Google forums in which someone has posted some jQuery that fixes the bug (albeit in a pretty hackish way):

    function reloadStylesheets() {
        var queryString = '?reload=' + new Date().getTime();
        $('link[rel="stylesheet"]').each(function () {
            this.href = this.href.replace(/\?.*|$/, queryString);
        });
    }
    
    if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){
     reloadStylesheets() ;
    }

    It works for me, I just hope I don't have to keep it forever.

    I'm confused why this is happening on the site I'm working on but not any other sites?

  26. ZachMatthews
    Member
    Posted 1 year ago #

    It's a timing thing rubious. I think you need to browse around long enough to trigger a 302 unchanged response from the server when you refresh a page you visited earlier. On my server I think the trigger time is 5 minutes, so you would just need to spend some time on one of these sites to start triggering it.

    Zach

  27. rubious
    Member
    Posted 12 months ago #

    Hi Zach,

    I've found my problem - I think it's your problem too!

    If you update the FitVids script to the latest version you'll find the problem is now fixed: https://github.com/davatron5000/FitVids.js

    It was that all along, we are both using it (and someone else who posted a link above).

    Glad that is finally sorted - and it explains why it was only happening on this site and not other sites I'm working on.. first time I used the FitVids script.

    Shaun

  28. pythonidea
    Member
    Posted 12 months ago #

    ptinning4

    I still did not fixed it, it seems when you refresh the site, the text will disappear...

  29. jkovach
    Member
    Posted 12 months ago #

    my previous thread on the issues I was encountering http://wordpress.org/support/topic/site-text-missing-on-chrome - related to same topic on this page thought I would back-link the pages for everyone...Ok everyone I found the answer after reading some more online forums here on WordPress and on Google and by doing some trouble shooting of my own. Every one kept thinking it was a cache issue as I thought the same thing as well, which is partially correct, but it has to do with the 304 return. That's why upon reload sometimes it works and sometimes it doesn't. The funny thing about this issue is that it's a simple fix. So simple everyone is going to scream when they find out how to resolve the issue for now. The issue is Google fonts. If you have Google Fonts or even a different font-face file loaded into your theme then you will have this issue currently in Chrome. It is a bug with the current version of Google Chrome. I have read that if you download the new beta Chrome Canary the issue has been resolved. To fix the issue simply change your text to a web safe font. I changed ours to standard Arial font and everything now works perfect and loads perfect. Also remember if you are using any inline font-style short codes you will need to change the font-style as well to a web safe font. Once everyone has changed over to the new Chrome or if Google fixes this bug will I then change back to custom fonts. Also if you are using a theme make sure to check all your misc-typography fonts and widget fonts for those will be effected as well. I hope this help you all!!! Thanks everyone for your continued support. If it wasn't for people like us writing on forums to help others do I really think WordPress or the Web-design world would be where it is today...

  30. rubious
    Member
    Posted 12 months ago #

    Hi jkovach,

    It's not Google fonts that are the cause of the issue, it's an old version of FitVids. I had a look at your site and you are using FitVids 1.0 (in this file: http://dealershiptracking.com/wp-content/themes/canvas/includes/js/third-party.js?ver=3.8.1 ) if you update that to the latest version (currently 1.1) it will fix your issue.

    https://github.com/davatron5000/FitVids.js

    I know this is the issue because I'm not using Google Fonts but had the same issue, and as soon as I updated FitVids the issue was fixed.

    Give it a go, and you can keep your fonts!

    Shaun

Topic Closed

This topic has been closed to new replies.

About this Topic