Support » Fixing WordPress » WP does not save the widgets in the widgets fields

  • Hello,

    I made a brand new installation of WP1.4.1. In the wp-admin panel > Appearance > Widgets, when I move the widget to the widgets area and press the Save button, the button never changes to Saved. After I reload the page or move to another page of wp-admin panel and then come back, the widgets area becomes empty and the chosen widget appears in Inactive Widgets area – so many times as I repeat the action. It happens with any theme (Twenty Fifteen, Mystile and others).
    I tried Firefox on Linux and Firefox and Chrome on Windows. Other admins experience similar phenomena on other computers.

    What could be the reason for such a behavior of WP1.4.1?
    Best regards
    Jacek

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    It happens with any theme (Twenty Fifteen, Mystile and others).

    – Try swithching to the unedited, Default Twenty Fifteen theme WITH ALL PLUGINS DEACTIVATED.

    – If all the above steps do not resolve the issue, then try MANUAL updating. Download a fresh copy of the WordPress .zip file to your computer, unzip it, and use that to copy up all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory. You may need to delete the old copies of files & folder on your server before uploading the new ones. Read the Manual Update directions first.
    If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong.

    Same thing here. Not a new install. This is an auto-update that was a surprise and now I can’t get any changes to widgets to save. They seem to save but the new settings don’t appear on the site. I’ll try reinstalling manually as suggested and will update afterwards.

    I deactivated all the plugins and made the manual update of WP. The result is that one theme with woocommerce saves and display the widget but the other theme doesn’t. Is it the problem of the other theme?

    Moderator t-p

    (@t-p)

    The result is that one theme with woocommerce saves and display the widget but the other theme doesn’t. Is it the problem of the other theme?

    that’s what it sounds like

    I did the reinstall, then found a new setting in a plugin. The combination of changes got everything running again. Mine is a wowthemes theme promoted with great tech support but with no tech support whatsoever. Tricky.

    Well. Now I noticed that when I add the widgets with Appearance Customize panel and not with Appearance Widgets all works fine so far, with exception of the left column in one of the themes. Unfortunately in this theme the widgets area we need the widgets in does not shows in Appearance Customize!
    And why saving of widgets with Appearance > Widgets does not work?
    Any ideas??

    Regards
    Jacek

    Moderator t-p

    (@t-p)

    Unfortunately in this theme the widgets area we need the widgets in does not shows in Appearance Customize!
    And why saving of widgets with Appearance > Widgets does not work?
    Any ideas??

    Try contacting the theme’s author.

    Try contacting the theme’s author.”¨¨

    I did it of course, but he is saying that it has never happened him before.

    However I think that if the widgets are not available in Appearance > Customize panel it can as well depend on either our WP configuration or the interaction between WP and the server.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP does not save the widgets in the widgets fields’ is closed to new replies.