Support » Plugin: No CAPTCHA reCAPTCHA » wp-debug error message when plugin is enabled

  • Resolved AJWD

    (@ajwd)


    First of all great plugin!
    Thank you for creating and offering this plugin.

    I am getting the following error when running this plugin (the message disappears when I disable it).

    Undefined index: captcha_wc_lost_password in /home/…/public_html/wp-content/plugins/no-captcha-recaptcha-for-woocommerce/lost-password.php on line 11

    It happens when I’m logged in as admin on every page.
    -A

Viewing 3 replies - 1 through 3 (of 3 total)
  • I will add that in my error log I have hundreds of the following:
    [27-Oct-2017 13:10:28 UTC] PHP Notice: Undefined index: captcha_wc_lost_password in …./public_html/wp-content/plugins/no-captcha-recaptcha-for-woocommerce/lost-password.php on line 11

    Followed by :

    [27-Oct-2017 13:10:29 UTC] PHP Notice: add_option was called with an argument that is deprecated since version 2.3.0 with no alternative available. in ….public_html/wp-includes/functions.php on line 4026
    [27-Oct-2017 13:10:30 UTC] PHP Notice: add_option was called with an argument that is deprecated since version 2.3.0 with no alternative available. in ….public_html/wp-includes/functions.php on line 4026
    [27-Oct-2017 13:10:38 UTC] PHP Notice: add_option was called with an argument that is deprecated since version 2.3.0 with no alternative available. in ….public_html/wp-includes/functions.php on line 4026

    I am getting the same error. Please advise a fix.

    The undefined index error was resolved by replacing no-captcha with a different security measure. The deprecated code error was caused by custom code that was pulling from the db. I removed the code and all is back to normal.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘wp-debug error message when plugin is enabled’ is closed to new replies.