WordPress.org

Forums

WP-DBManager
[resolved] wp-dbmanager not seeing backup-db, chmod 777? (7 posts)

  1. Bill
    Member
    Posted 1 year ago #

    I'm trying to run a backup for the first time with my new server configuration. I just worked through the ".htaccess visible" problem but now I still have this error message:

    "Checking Backup Folder (/home/hollyhouse/hollyhouse.org/wp-content/backup-db) ...
    Backup folder does NOT exist. Please create 'backup-db' folder in '/home/wp_exz2u6/hollyhouse.org/wp-content' folder and CHMOD it to '777' or change the location of the backup folder under DB Option.
    Backup folder is NOT writable. Please CHMOD it to '777'."

    The thing is that the folder does exist and the CMOD file attribute is set at 777. So, questions:

    1) why am I getting this error message?
    2) should I set subdirectories or file to 777 as well or just "backup-db"?
    3) does this setting compromise the security of my site?

    I look forward to your response.

    http://wordpress.org/plugins/wp-dbmanager/

  2. Lester Chan
    Member
    Plugin Author

    Posted 1 year ago #

    1) Does it still get backup correctly despite the problem?
    2) Just backup-db will do
    3) Depends, it is a tough to answer, you can set the backup folder outside your web folder so that it cannot be access via URL to make it safer.

  3. Bill
    Member
    Posted 1 year ago #

    Hi Lester,

    1) No, backup fails. I still need to resolve this. Any thoughts?
    2) Got it.
    3) I'm not sure what level is "outside my web folder". If I show you my folder tree, can you point out the best level?

    FIRST LEVEL
    "home"

    SECOND LEVEL
    "user name"

    THIRD LEVEL
    ".php"
    "sitename.org"
    "logs"
    "Maildir"

    Maybe, that's enough. Are you talking about putting anywhere outside "sitename.org" on LEVEL 3?

  4. Lester Chan
    Member
    Plugin Author

    Posted 1 year ago #

    "Maybe, that's enough. Are you talking about putting anywhere outside "sitename.org" on LEVEL 3?" -- Yeap

    If backup doesn't work, you need to debug it with SSH access

    1. In wp-dbmanager.php
    2. Find check_backup_files(); (around line 208)
    3. Add below it echo $command;
    4. Go to WP-Admin -> Database -> Backup
    5. Click Backup
    6. It should print some debugging line like the one stated in this thread previously.
    7. Copy that line than run it in SSH.
    8. If you need help on SSH contact your host or google for more info.

  5. Bill
    Member
    Posted 1 year ago #

    Thanks Lester! Backup now working!

    I'm now trying to switch to a backup folder outside my site as you suggest but, even though I update and save the revised folder path in backup options, the program doesn't seem to want to let go of the default location. When I reenter DB Options of Backup DB, the old path is presented. If I run the backup, the program saves it to the old default location.

    What do I need to do to change the backup folder location?

  6. Lester Chan
    Member
    Plugin Author

    Posted 1 year ago #

    I can't reproduce the problem on my dev install. I am able to change the backup path. Are you using any caching plugin?

  7. Bill
    Member
    Posted 1 year ago #

    Hi Lester,

    Turns out this had something to do with my hosting setup. Seems to be working now. Sorry, for bothering you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic