WordPress.org

Support

wp-db-backup

  • Hello! I have installed the wp-db-backup 1.5 plugin and activated it, I then click on the backup tag and get the warning “WARNING: Your backup directory is NOT writable!”

    Sooo I am stuck in my tracks.

    HOW do I make the directory on the server writable?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You need to change the permissions of the backup folder to 777. You can do this through a website control panel or your ftp client.

    I have tried doing this with wsftp95 with no result and I have gone to the website control panel and can’t see any where there from which I can do it either!

    I wonder if my version of the program is up to it and I suspect my idiot host dosn’t let me do it either.

    Does anyone know a XP complient ftp program I can download that would let me do the cmod 777 on a linux server?

    I would be grateful because I finally got my blog running properly and I don’t want to ask my host to do anything because their people will simply mess it up for me with impunity.

    Filezilla is good: http://sourceforge.net/projects/filezilla

    See: FTP_Clients

    Added note: and it’s easy to change file/directory permissions by right clicking and accessing File attributes!!

    Hello again..

    I have been able to change the directory permissions to 777 and I ran the backup…And got an A4 page worth of warnings viz…

    Warning: fwrite(): supplied argument is not a valid stream resource in /vhost/vhost2/c/a/m/campbellconsent.com/weblog/wp-content/plugins/wp-db-backup.php on line 122

    Warning: fwrite(): supplied argument is not a valid stream resource in /vhost/vhost2/c/a/m/campbellconsent.com/weblog/wp-content/plugins/wp-db-backup.php on line 123

    All the way to line 213 pretty much the same.

    The backup did say it was successful and I have been able to download a file with an .SQL extension.

    Thing is I don’t know what a back up is supposed to look like and I am insecure that I may have a rubbish backup. I don’t want to find out its rubbish at the very time I may need it.

    Could someone tell me how to check if its a valid backup or does anyone know what it is I actually got?

    And..Please excuse my bad manners..Thanks to you both so far.

    Actually if anyone answers my last question perhaps you could tell me WHAT do I do with the .SQL file if indeed I did suffer a server catastrophe?

    ” Points I missed:

    *SHOW CREATE TABLE Resource id #28

    *WordPress database error: [Table ‘campb876.Resource’ doesn’t exist] DESCRIBE Resource id #28

    *WordPress database error: [Table ‘campb876.Resource’ doesn’t exist] SELECT * FROM Resource id #28 LIMIT 0, 10

    Warning: Cannot modify header information – headers already sent by (output started at /vhost/vhost2/c/a/m/campbellconsent.com/weblog/wp-content/plugins/wp-db-backup.php:122) in /vhost/vhost2/c/a/m/campbellconsent.com/weblog/wp-content/plugins/wp-db-backup.php on line 53

    I have a few mor like this last one refering to different line numbers.

    Hope they can be explained.

    Thanks

    For the errors question–did you click/check any but the core files to backup?

    Did you choose to backup to wp-content/backup or download to computer or email backup to option?

    Once the Backup! button was pressed did you see the progress bar on your screen? If so did it move to the right as the backup progressed?

    For “WHAT do i do with the .SQL file…” question look at this: Restoring_Your_Database_From_Backup

    Hello MichaelH!

    I answer your Qs as follows:

    *I did try to add everthing, that is; I cheched ALL the boxes to the right of the core files.

    *I downloaded the backup to my computer.

    *I did not see a progress bar after pressing the backup button.

    Thanks

    As for the restore from my backup file:

    I used wp-db-backup to do the back up …The link you gave me describes the backup using phpmyadmin..

    I imagine this dosent apply?

    Please confirm.

    Those restore instructions will use the .SQL file.

    OK…

    Will I be able to restore when I don’t have direct access to my MYSQL database though?

    I don’t use phpmyadmin, I have found it terribly difficult to use..is this required?

    my host doesnt give me access from control panel.

    BTW do you think I should run backup again without the extras?

    I have run the backup again. This time without the extras..I got no error messages.

    I did not however see any progress bar.

    Sorry to keep coming back to you..its just that I don’t know what to look for as I have no experience with backups.

    If you have phpMyAdmin access then you should be able to restore from that .SQL file. If you don’t have access to any type of control panel or command line access then check with your host and ask how often they backup their sql database server and ask what procedure you would follow in the event you need to restore your database(s).

    The progress bar was added in v1.6 of wp-db-backup so maybe you have to upgrade to v1.7.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘wp-db-backup’ is closed to new replies.
Skip to toolbar