Support » Plugin: WP-DB-Backup » wp-db-backup produced an empty .sql file

  • I’m moving a blog so I ran the wp-db-backup and downloaded the resulting file. Now I uploaded the .sql file and it is empty. I had selected all of everything to be backed up but the backup only contains:
    # WordPress MySQL database backup
    # Generated: Monday 13. December 2010 17:58 UTC
    # Hostname:
    # Database: rob0917606452347
    # ——————————————————–
    I logged in to my new host and went to phpmyadmin to try to import what I thought was my backup but got only the contents showing. Not knowing what any of it was for, I tried clicking “go” and got nothing. I tried to visit hosted to see if there was anything there, but there’s no such place. I’m not all that prolific at using mysql and my site is gone.
    How can I get two years of content back? Help?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Austin Matzko


    What version of the WP-DB-Backup plugin are you using, and what version of WordPress are you trying to use it on?

    I pointed the DNS back to the old host and just put the old site back where it was. Since I still have a few months of hosting there I will redo the move when I have more time. I can’t tell what version it was because I removed all the plugins trying to get the site visible again, but I do know that I kept WP and all plugins up to date so it was the current version on Dec. 13, 2010 when the backup was done. The WP-DB Backup plugin that I have now was installed new today. I’ve done this before using the WP-DB Backup without a problem. When I get ready to move it again, I will check before editing the DNS to be sure I have what I need.
    I am bewildered as to what went wrong because I always use the plugin to back up everything before I do a WP update and the few times I ever needed to check, it has been a .zip file and had everything there. Since the original db was cached on the host it all worked out OK.
    Thank you!



    I thought it might be easier to start where I left off than to start a new thread because the above information helps the rest make sense. This is long.. In preparation to move the site this week I did more than one backup, but they did not download and went instead to a backup folder inside WP even though the radio button to download was checked. The site I am moving is not my creation, I am helping a friend move his site. When we put the site back up on it’s old host last Dec. it was fine. To move it to the new host I ftp’d all the files to a folder on my computer and then ftp’d them in to the same new host where we had tried before. On importing the .sql file into the existing database there was an error but it appeared to be working fine. I think it looked OK because the DNS change had not taken effect yet. Within half an hour it was still OK, but there was a error message from a plugin across the top of the front page. I deleted the plugin with the error and then went to log in to Admin. While logging in to Admin, I got this notice:
    Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    There is no way to bypass and run an update via the dashboard so I clicked “OK”. The update took about 2 seconds, and since the update, all files created after the original move in Dec. are gone. After the update it was impossible to log in to Admin. Clicking on the “lost password” link on login allowed the password to be changed, but it still does not allow Admin login.

    The version of wordpress that had been installed on the server was not changed, but the old existing install was deleted prior to moving all the files into the domain, we had updated WP to the latest version just before backups.

    Since this problem, after talking with tech support at the new host (westhost) first I dropped all tables and imported again, got the same error and again the site was missing all posts since Dec. Then I created a new db and copied that info into wp-config.php and wp-settings.php. The import went fine, but it is missing all files since Dec. I did and Export (.xml) prior to the move and I haven’t used that file because I can’t log in to Admin. Obviously I’ve done something wrong, but have no idea where to look. I have done a search here and similar cases are several years old many unresolved. The db on the previous host (GoDaddy) is probably still there, I haven’t logged in there to see if I can get it out. I recall trying that last Dec with no success. I am thinking I will need to delete this whole thing, install a new WP and try moving all these files into it but if building a new db and importing from backup is missing files, they will be missing no matter what I do. Hoping to be able to log in and do an import instead? Suggestions? Help?
    Thank you.



    I found the db issue: The backup file at 63 Mb was over the size limit for import via phpMyAdmin, it had to be manually imported. Now there is only the problem of not being able to login to Admin.



    Disabled all plugins which let me log in again, from here I will manage.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘wp-db-backup produced an empty .sql file’ is closed to new replies.