WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WP Database Error

[Resolved] WP Database Error

  • Ok,

    I made mistake not to deactivate all the plugs when updating (I’ll never do it again, I swear), so when I went from 2.05 to 2.06 I get this whenever I upload something or create new page ;

    WordPress database error: [Unknown column ‘none’ in ‘field list’]
    INSERT INTO wp_post2cat (post_id, category_id) VALUES (116, none)

    Warning: Cannot modify header information – headers already sent by (output started at /home/mydomain/wp-includes/wp-db.php:104) in /home/mydomain/wp-includes/pluggable-functions.php on line 270

    I would appreciate any help so I wouldn’t have to go writing all the posts all over again, I’ll do it if there is no fix for this but if there is, I’d be very grateful.
    Thanx

Viewing 3 replies - 1 through 3 (of 3 total)
  • It does sound like a plugin conflict.
    You tried deactivating all of them and reactivating them one by one?

    Yes,
    Another thing I tried was to make a fresh install of 2.07 and use the same plugs, everything worked normally, it’s only that my upgrade got this. Unfortunately I didn’t back-up my database either… (stupid, stupid, stupid!)
    If you have solution, please help, can I fix the database, what can I do…
    Greetz Daddo

    Well,
    Yes it’s resolved now, thx to 2.1 that has implemented a xml feature to export your posts, categories and pages, there was quite a bit of job to get it all back to way it used to be, but it was not as frustrating as I was expecting it to be.
    thx.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WP Database Error’ is closed to new replies.
Skip to toolbar