Support » Plugins » WP Customer Reviews, avoid if you want to keep your sanity.

  • I downloaded this plugin, version 2.4.1 in August. I prepared over 500 reviews in a CSV file. I imported all my reviews, including a custom field. It was working fine. I upgraded to 2.4.2 and my custom field now displays at random, or only for entries I enter manually from the front end, and maybe 1 out of 10 for the ones I previously imported. I finally got the developer to send me ver 2.4.1 again, tried working with that in various ways but the problem remains. The developer is too busy to help, I offered to pay to fix the problem. This plugin will make you want to put a gun to your head when it goes wrong.

Viewing 5 replies - 1 through 5 (of 5 total)
  • This isn’t an issue with the plugin, but with the custom import. The plugin itself does not have an import function. The custom field data is serialized and must be very specifically entered in the database (which is why it works when you enter a review using the plugin itself).

    My first guess why the imported fields are not displaying is because the data is serialized all in a single column. With serialized values, the # of characters in the field must match up with the # after the “s:” or else PHP will ignore it. I’m not sure who created that import for you, but they need to take that into account. It has been this way since custom fields were introduced, so nothing that would have changed with the custom field format in the database from version to version.

    Hope this helps!

    Ahhhhhhhhhhhh I wish you had taken your first guess months ago. This was indeed the problem. I set up the import, I didn’t know the meaning of the s: and I made them all s:13 as that was what I saw in the sample that I exported to get the correct format. The strange thing is that it was previously working correctly even when all the s: numbers were set the same on the first import. This is really bizarre stuff, but yeah now I have a lot of manual fixing to do. Thank you for finally letting me know what was wrong though.

    Sorry for the delay, but life gets busy!

    Hopefully updating those values will solve the issue… I’ve seen that before in another project and if I remember correctly, it will cause all kinds of randomness if the number of characters is off. What you probably saw was the field coming through for every single review that was 13 characters in that field 🙂

    Let me know when you update this if it fixes the issue.

    Yes, it’s fixing the problem, I’m having someone count the characters and changing the s value for each one.. It’ll take some time, but it is working. What I meant was, when I first got the plugin, I input one entry manually and exported it to CSV from phpmyadmin so I could see the structure and format the rest of the reviews. That particular entry was s:13 so I (not knowing what that meant) made all reviews s:13 and it DID work until I upgraded to 2.4.2. The fact that it worked before the upgrade is the part that makes no sense.. Oh well, at least I have the fix now… So do you think it’s safe to upgrade again to 2.4.2?

    Once the data is all correct, 2.4.2 should be fine. As always, just perform a file and db backup before just in case.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP Customer Reviews, avoid if you want to keep your sanity.’ is closed to new replies.