Support » Fixing WordPress » WP Cron issues

  • Resolved marcazonca

    (@marcazonca)


    I have a weird issue that I have been ignoring for a while now. I vaguely remember but a couple years ago I had issues with my Scheduling of posts. It used to work fine but I forget if it was a plugin that messed it up or what happened, but my wp_cron was disabled in the wp-config.php file. I had an error message in my updraftplus saying there was 30 something scheduled jobs that haven’t gone through basically. So I decided to try and take a look at this as I would like to schedule posts once again. I changed the value of define(‘DISABLE_WP_CRON’, true); to false and now when I simply try and update a page, it just turns and turns and never ends up saving. My Dashboard is missing stuff and when I got to my site, I lost the WP bar at the top to edit the page or whatever. I tried to add the define( ‘ALTERNATE_WP_CRON’, true ); with no luck. I compared my wp-cron.php file and it seems correct as far as I can tell. I don’t know what the issue is here. It would be nice to fix this if someone could help me out.

    • This topic was modified 2 months, 1 week ago by marcazonca.
    • This topic was modified 2 months, 1 week ago by marcazonca.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p

    (@t-p)

    The Schedule posts are published through the WordPress Cron, and the WordPress Cron relies on traffic/visitors on the website to keep track of time and execute scheduled tasks. To put it otherwise, unlike regular cron jobs, which run at specific time based on the server settings, the WP-Cron function runs every time someone visits the WordPress powered website. This makes a WordPress site run properly on different kinds of server setups because it eliminates a lot of server-specific requirements. On every page load, WordPress checks if there is a need for WP-Cron to run. If there is a need, then it tries to make a request over HTTP to the wp-cron.php file. So if your website does not have any visitor at the scheduled time of the post the Cron will not run and in turn, the post will not be published. However, the missed Cron will automatically run when a user visits your website. – The Schedule posts are published through the WordPress Cron.

    And a broken cron is quite often also related to failing loopbacks.

    Check Site Health if it throws any message about loopbacks.
    Dashboard -> Tools -> Site Health

    Thread Starter marcazonca

    (@marcazonca)

    My Site Health says it’s good with no errors. I changed the define(‘DISABLE_WP_CRON’, true) back to true and I still could not update a page. It just spins and spins without ever completing. So I thought maybe I should reboot the server and after doing that, the same thing is happening. I’m not sure why. All I did was set that define(‘DISABLE_WP_CRON’, true) to false, cleared my cache, uninstalled 3 plugins that weren’t being used. I’m not sure why now all of a sudden I can’t even update a page.

    Moderator t-p

    (@t-p)

    I’m not sure why now all of a sudden I can’t even update a page.

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install and activate “Health Check”: https://wordpress.org/plugins/health-check/
    It will add some additional features under the menu item under Tools > Site Health.
    On its troubleshooting tab, you can Enable Troubleshooting Mode. This will disable all plugins, switch to a standard WordPress theme (if available), allow you to turn your plugins on and off and switch between themes, without affecting normal visitors to your site. This allows you to test for various compatibility issues.
    There’s a more detailed description about how to use the Health Check plugin and its Troubleshooting Mode at https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/

    Thread Starter marcazonca

    (@marcazonca)

    You know what I just got it fixed. I appreciate your help. I literally just did a log off and log on again and my Dashboard was back to normal, I was able to update my page and the wordpress admin bar is now showing up on my website again. I changed the define(‘DISABLE_WP_CRON’, true) back to false and it’s still working fine. Thanks for your help.

    Moderator t-p

    (@t-p)

    Glad its sorted 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.