Support » Plugin: Editor Menu and Widget Access » wp crashes after plugin upgrade to 3.1

  • Resolved gstory20

    (@gstory20)


    After I upgraded the Editor and Menu Access plugin to 3.1 my web site crashes with the following log message:

    [Sun May 30 15:05:06.231973 2021] [php7:error] [pid 22874] [client 63.117.14.9:43782] PHP Fatal error: Uncaught Error: Call to a member function add_cap() on null in /nas/content/live/gmcastaging/wp-content/plugins/editor-menu-and-widget-access/admin/caps.php:37\nStack trace:\n#0 /nas/content/live/gmcastaging/wp-includes/class-wp-hook.php(292): emwa_set_capabilities('')\n#1 /nas/content/live/gmcastaging/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array)\n#2 /nas/content/live/gmcastaging/wp-includes/plugin.php(484): WP_Hook->do_action(Array)\n#3 /nas/content/live/gmcastaging/wp-settings.php(560): do_action('init')\n#4 /nas/content/live/gmcastaging/wp-config.php(120): require_once('/nas/content/li...')\n#5 /nas/content/live/gmcastaging/wp-load.php(37): require_once('/nas/content/li...')\n#6 /nas/content/live/gmcastaging/wp-blog-header.php(13): require_once('/nas/content/li...')\n#7 /nas/content/live/gmcastaging/index.php(17): require('/nas/content/li...')\n#8 {main}\n thrown in /nas/content/live/gmcastaging/wp-content/plugins/editor-menu-and-widget-access/admin/caps.php on line 37

Viewing 15 replies - 1 through 15 (of 17 total)
  • I get the same error with the latest version of the plugin.

    I have WordPress version 5.7.2 and the latest update of Editor Menu and Widget Access (3.1) and I also get the same error message.

    I have got the same issue
    /public_html/wp-content/plugins/editor-menu-and-widget-access/admin/caps.php:37

    I’m getting the same error as well on a number of sites. Have disabled the plugin so I can get my sites back online.

    Martin

    (@martinpwph)

    Yep same error on five sites using this 3.1 version crashed.

    The 3.1 update seems to only work if the WooCommerce plugin is also installed as it adds the Shop Manager role.

    Getting the same here

    I’m getting the same error

    /public_html/wp-content/plugins/editor-menu-and-widget-access/admin/caps.php:37

    Same here on multiple sites.

    I have the same problem after updating. If there is a solution for this, I would be grateful for a hint on how I can safely reactivate the plugin. At the moment I just disabled it completely in wordpress recovery mode.

    Best regards,
    Felix

    Plugin Author GuyPrimavera

    (@guyprimavera)

    Thanks for letting me know.

    Investigating now and will release a fix shortly.

    Thanks @guyprimavera ā€“ we’ve also had a few pages report critical errors this morning. All on 5.7.2 as well.
    Mario

    Plugin Author GuyPrimavera

    (@guyprimavera)

    No worries.

    New version with bugfix released. Please update to 3.1.1 and let me know if there are any issues.

    Sorry for the bug in the previous version guys, this update should resolve everything.

    Thanks

    Thanks @guyprimavera ā€“ i can confirm that on our installations the problem is fixed.
    Mario

    Plugin Author GuyPrimavera

    (@guyprimavera)

    Awesome, thanks for letting me know! I’ll mark this as resolved for now and re-open if anyone still has issues after updating.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.