Support » Plugin: Slimstat Analytics » wp-crash after update to 4.4.3

  • Resolved micha15295

    (@micha15295)


    After the update the whole installation does’nt work anymore; only solution to get access is to delete the plugin via FTP.
    That’s the warnings that I got after the update:

    Warning: include_once(/www/htdocs/xxxxxxx/wp-content/uploads/wp-slimstat/browscap-db.php): failed to open stream: No such file or directory in /www/htdocs/xxxxxxx/wp-content/plugins/wp-slimstat/browscap/browser.php on line 20

    Warning: include_once(): Failed opening ‘/www/htdocs/xxxxxxx/wp-content/uploads/wp-slimstat/browscap-db.php’ for inclusion (include_path=’.:/usr/share/php:..’) in /www/htdocs/xxxxxxx/wp-content/plugins/wp-slimstat/browscap/browser.php on line 20

    Warning: unlink(/www/htdocs/xxxxxxx/wp-content/uploads/wp-slimstat/browscap-db.php): No such file or directory in /www/htdocs/xxxxxxx/wp-content/plugins/wp-slimstat/browscap/browser.php on line 26

Viewing 15 replies - 16 through 30 (of 48 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Everybody, if you update Slimstat to version 4.4.3, the error should be fixed. Please let us know if that’s the case.

    To those who are experiencing a memory limit issue, this is probably related to the latest version of Browscap, which was released no more than a couple of weeks ago, which contains many new strings, making the data file bigger. Please increase your PHP memory limit to solve the problem, or if you can’t, uninstall Browscap so that Slimstat will be using the built-in heuristic function (less accurate, but less resource intensive).

    Thank you for your patience. I’m sure once you are all migrated to 4.4.3, the world will be a better place 😉

    Best,
    Jason

    Plugin Author Jason Crouse

    (@coolmann)

    Also, the Fatal Error issue should be now resolved even if you keep version 4.4.2. However because we had to push a fix for PHP 5.6, if you don’t upgrade, Slimstat will not be able to determine the visitor’s browser name and operating system, and it will display a question mark instead. If that still doesn’t solve the problem, please delete the file browscap-db.php under /wp-content/uploads/wp-slimstat/ to allow the plugin to install the new one.

    • This reply was modified 1 year, 1 month ago by  Jason Crouse.
    Plugin Author Jason Crouse

    (@coolmann)

    Please note: DO NOT UNINSTALL your current version or you will lose all your data!!!

    Follow these steps to upgrade: delete the file browscap-db.php in /wp-content/uploads/wp-slimstat and the 500 error should disappear in version 4.4.2. Then go to Plugins and upgrade to version 4.4.3 and let the plugin install the new version of browscap-db.php for you. It should work from there.

    I have erase by ftp the 4.4.3 version and after this I have put, by ftp the version 4.4.1 and work and I haven’t lost the data. Please inform when the 4.4.3 version work fine.

    Hi Jason,
    with your given instructions all work fine now.
    But I think there’s a little mistake; on my side the path to the browscap-db.php
    is /wp-content/plugins/wp-slimstat/browscap/

    With best regards, Michael

    I had the browscap error in 4.4.2 and removed the plugin via FTP to get the site working. I just updated my dev version (PHP 7) to 4.4.3 and nothing works. This is the error:-

    Parse error: syntax error, unexpected ”a:3:{i:3;i:64152;i:12;s:4:”tr’ (T_ENCAPSED_AND_WHITESPACE), expecting ‘)’ in /srv/www/dev.wp6/wp-content/uploads/wp-slimstat/browscap-db.php on line 1013

    • This reply was modified 1 year, 1 month ago by  Sriom.
    Plugin Author Jason Crouse

    (@coolmann)

    @sriom, what’s the size of browscap-db.php in wp-content/uploads/wp-slimstat ? It sounds like the server was not able to install the file correctly, and it is corrupted or truncated.

    Plugin Author Jason Crouse

    (@coolmann)

    @micha15295 you are correct, that’s the other location where the file should be, if you’re still running Slimstat 4.4.2

    @coolmann; browscap-db.php is 5,418,292 bytes.

    • This reply was modified 1 year, 1 month ago by  Sriom.
    Plugin Author Jason Crouse

    (@coolmann)

    @sriom what is your PHP memory limit?

    Looks as though it was a temporary glitch. All working now. Thanks for the help.

    Plugin Author Jason Crouse

    (@coolmann)

    @sriom that’s great news! Terrific and thank you again for your patience!

    Same thing for me… disable slimstat and the site came back. please advise.

    well its working now… thnxx

    • This reply was modified 1 year, 1 month ago by  linkzeroct.
    Plugin Author Jason Crouse

    (@coolmann)

    @linkzeroct just update to version 4.4.3 and everything will be back to normal.

    Mine is still broken.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 19922944 bytes) in /home/content/11/7539211/html/wp-content/uploads/wp-slimstat/browscap-db.php on line 65540

    Updated to 4.3.3, problem arrived wen using 4.3.2
    WP is at 4.6.1
    PHP 5.3

    Have disabled WP by adding the word “disabled” to the end of the Slimstat plugin folder numerous times. My site works when WP Slimstat is disabled. This was suggested by the TS folks at GoDaddy.

    Removing “disabled” I then test it from my computer I usually use, at home, it works for a little while, sometimes a few hours.

    Recently bumped the memory to 256M, then 384M in the PHP.ini file. and it worked at home. I checked it from my iphone on the road and got the fatal error again, so have once again disabled.

    Here is first few lines of .ini file:

    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    memory_limit = 384M ** this line not present when error arrived, added, set to 256M, then 384M
    variables_order = “EGPCS” ** problem persists
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = “a=href,area=href,frame=src,input=src,form=,fieldset=”

    What do I need to do to get slimstat working again?

    thank you

    • This reply was modified 1 year, 1 month ago by  coastodian.
Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘wp-crash after update to 4.4.3’ is closed to new replies.